Router is set as Upstream in Pi-hole then what?

#1

So I used this guide: How do I configure my devices to use Pi-hole as their DNS server?

I went with option 2. Configured Pi-hole to use Upstream DNS with my router. Added the router dnsmasq config as well. However all my queries, after going to the router, go to my ISP DNS. How do I avoid this? I’d like to use any of the recommended servers in the guide but if I add the address to my router wont it skip the pi-hole altogether? I must be missing something so simple but I can’t see it.

Thanks for your help

0 Likes

#2

The setup per that option is client > router > pihole > router > third party DNS.

If you don’t have the dnsmasq dhcp option set properly in the router or if the router doesn’t support that, then the router won’t send it’s traffic to the Pi-Hole.

0 Likes

#3

Ok thanks for the clarification. I may have missed a config step. I have DD-WRT.

  1. Router with dnsmasq dhcp option 6 to pi-hole IP
  2. Pi-hole upstream to router IP
  3. ??? (do I put 3rd party address in the basic setup for static DNS?)

Thanks

0 Likes

#4

Ok so I’ve been digging through discourse all day trying to understand how to direct traffic to 3rd party DNS at the end of the workflow; client -> router -> pihole -> router -> 3rd party. I like this method of setup because of the hostname traffic identification, even if I have to edit the hostnames list. Both guides I’ve found state that adding a 2nd static DNS to the router will negate the pihole.

I’ve searched all over and the closest answer I got is using Cloudflare and DNS over HTTPS but I see that the upstream DNS in the pihole is no longer the router but cloudflare instead. I don’t know if this the right answer but I can’t find anything else. Should I continue with this setup? Can it still log each device’s traffic?

0 Likes

closed #5

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes