Router config doesnt accept RPI IP as DNS [Ubee EVW3226_1.0.16]


#1

Hi. The issue just might be external, but I am willing to give it a try :slight_smile:
Setup is on RPI 3 with Raspbian. Running Windows 7 machine with DNS configuration directly on it.
Router: Ubee EVW3226_1.0.16
RPI ifconfig:
eth0 Link encap:Ethernet HWaddr b8:27:eb:4f:b1:3e
inet addr:192.168.0.250 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::c28a:e52a:7e66:df01/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10029 errors:0 dropped:50 overruns:0 frame:0
TX packets:8650 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1168402 (1.1 MiB) TX bytes:3419251 (3.2 MiB)

I want to move DNS config to the router according to How do I configure my devices to use Pi-hole as their DNS server? . Unfortunately, the router does not recognise RPI IP as valid thus not allowing to change DNS to RPI.
Screenshots:
Entering DNS: https://ibb.co/fVQpt5
Pressing Save: https://ibb.co/fZMvY5

Changing to publicly available DNS (like 8.8.8.8) or to basic config (192.168.0.1) doesnt generate that problem.

Anyone had any problems like mine?
I am stil to try managing DHCP through pihole, but I dont really like the risk of being cut out and forced to hardreset the router.
I have raised this issue on github. One user suggested that the router simply doesnt accept internal adresses as DNS servers. (https://github.com/pi-hole/pi-hole/issues/1411)


#3

Did you disabled the DHCP server on your router after enabling pihole as DHCP?


#4

I havent tried to enable pihole as DHCP yet, will try to do that in few hours.
I have (foolishly) disabled DHCP on router and had to restart it because I got cut out.


#5

Is the router issued by Time Warner Cable?
After googling what I found was that Time Warner cable doesn’t allow users to change the DNS server. However the user manual says that it is possible.


#6

No, its UPC (Poland).
There is information in the manual (https://pl.scribd.com/document/253978440/Ubee-Evw3226-Manual) but there is no mention of restrictions. I can change DNS, just not for RPI IP (or any other local apart from 192.168.0.1).
May be my ISP also blocks it in some way, will call them and ask about it.


#7

Oh! I forgot to mention that the WAN DNS values specify the server that the router will use for its upstream DNS (if you don’t want to use your ISP’s servers). The LAN DNS servers are the addresses that DHCP will give out to clients on your LAN instead of itself.
So try setting pihole IP under WAN DNS


#8

ISP’s Helpdesk says that they dont block it but “changing DNS is not supported on this device (model)”.

Unfortunately, neither on router setup or in manual, there is no mention of WAN DNS.


#9

Your best option will be using the Pi-hole’s DHCP, or manually configuring all clients.


#10

I think so too. Will try changing to pihole DHCP today.