Raspberry Pi OS (bookworm) is out now, Pihole error "Unsupported OS detected, Debian 12"

Just a hint: The new Raspi OS is out now

A fresh installation of Pihole fails due to error mentioned above.

Please indicate if waiting for Pihole 6 in combination with OS update (bookworm) makes sense.
Bullseye and Pihole work fine for the moment.

Use the "unsupported" modification in the installer and this version will likely run fine.

curl -sSL https://install.pi-hole.net | PIHOLE_SKIP_OS_CHECK=true sudo -E bash

I updated my Raspbian Bullseye to Bookworm, used the installer/updater bypass, and am seeing no problems in Pi-hole.

The applicable commands are:

for new install:

curl -sSL https://install.pi-hole.net | PIHOLE_SKIP_OS_CHECK=true sudo -E bash

for an update:

PIHOLE_SKIP_OS_CHECK=true sudo -E pihole -up

Note that as of now, this OS is officially not supported, but early indications are that it works fine with Pi-hole.

1 Like

Mine looks to be good here. My own stumbling block was setting a static IP address using network manager. Raspberrypi.org's documentation just says set a reserved address on your router which isn't much use when your pi is your DHCP server.
The command is nmcli connection modify Wired\ connection\ 1 ipv4.method manual ipv4.addresses ipv4.gateway ipv4.dns ipv4.dns-search example.com
with your choice of IP address, gateway, DNS

1 Like

In Raspbian, this was previously done in file /etc/dhcpcd.conf.

interface eth0
    static ip_address=
    static routers=
    static domain_name_servers=

Edit: the Bookworm release notes have additional information on the shift from dhcpcd to network manager.

1 Like

That's how we are all used to doing it but with Raspberry PiOS Bookworm I don't think we get the option of dhcpcd. It defaults to NetworkManager where with Bullseye it was an option, defaulting to dhcpcd.

Not in my install. Maybe because I did an in-place upgrade and not a fresh install of Bookworm.

I do see an option in the raspi-config command on the Pi to use dhcpcd. That (on my older install) is the only option presented.

Are you using Raspbian and not Raspberry Pi OS. Raspberry Pi OS is based on Raspbian.

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 12 (bookworm)"
NAME="Raspbian GNU/Linux"
VERSION="12 (bookworm)"

This particular install started out at Stretch as I recall. It's quite old.

cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 12 (bookworm)"
NAME="Debian GNU/Linux"
VERSION="12 (bookworm)"
SUPPORT_URL="Debian -- User Support"

A fresh install of Raspberry Pi Os

from the release notes:

NetworkManager used instead of dhcpcd as networking interface; various changes made to networking plugin to support this

workaround, if you don't want to use networkmanager:

sudo apt-get -y remove network-manager
sudo apt-get -y install dhcpcd
sudo apt-get -y autoremove
1 Like

Can I ask:

Will we non-technical users be notified on these forums when a new version of Pi-Hole (that runs without workarounds Raspbian 12-Bookworm) is released?

Or will it simply be "Pi-Hole v.6"?

1 Like

We likely won't release an update to Pi-hole to add support for Raspbian Bookworm (unless changes to our code are required), but we will update our list of supported OS's so the installer will stop throwing the error.

Typically we will announce this in this forum and in our subReddit.

You can check the list of supported distros with this command at any time. This is where the installer/updater gets the list.

dig +short -t txt versions.pi-hole.net @ns1.pi-hole.net


OK, many thanks.

I did an in-place upgrade to Raspberry Pi OS Lite (64-bit) Bookworm - works flawless.
Then I tried a fresh install, flashing Raspberry Pi OS Lite (64-bit) Bookworm then installing Pi-hole. That's when I learned /etc/dhcpcd.conf doesn't exist in the new image and changes in /etc/dhcp/dhclient.conf don't work to set a static IP.
Raspberry Pi 5 start shipping later this month and Raspberry Pi OS - Bookworm is the only officially supported OS for the Pi 5.
Several people upgrading or setting up Pi-hole on their new Pi 5 are going to run into this NetworkManager issue and 99% of what they will find when they Google how to set a static IP on a Pi will direct them to edit /etc/dhcpcd.conf.
At the very least the solution should be easier to find in the forums and not tucked in an "Unsupported OS" string.

Agree with Emergency_trust_2639

To the team that builds and maintains this software and related documentation. I cannot thank you enough for what you do.

Most of the problems that I google for point me to solutions for older versions. Something that the PI and PIhole teams do not control.

May I humbly suggest, It would be nice if there was a table somewhere of probable issues and the corresponding new command that would be needed.

As an end user who does not spend much time on the forums and documentation I did not realize the RPI imager installed Bookworm on my new SD card. Running headless I just ssh in and started the PIhole install only to fail. That's when I hit google with the error and came to this page. I will now try with the OS check bypass command above and am sure will have no issues until I move the SD card to the other RPI and have no idea if I will need to make any changes because the ip which is static and assigned by the router will cause an issue. fingers crossed.

UPDATE : yes the OS bypass worked and Pihole is Up. unable to copy the details displayed of the "Installation Complete" popup. Am connected to the PI from a Windows 11 Laptop and using the built in SSH. If that matters.

1 Like

dhcpcd being replaced by NetworkManager in Bookworm has nothing to do with Pi-hole's installer reporting an unsupported OS.
RaspberryPi OS 12/Bookworm was released four days ago and is indeed not yet officially reported by Pi-hole - it will be added once we find the time to pass the tests.

In addition, the PIHOLE_SKIP_OS_CHECK workaround is not tucked away somewhere where you can't find it - the Pi-hole installer prints the related instructions straight away when it detects an unsupported OS.

Thanks for highlighting that. I must not have seen it :smile:

I agree, that's why I stated the instructions to help people figure out how to set the static IP shouldn't be in this thread. Maybe I should start a "Raspberry Pi OS Bookworm static IP issues" in the help section, then post the solutions, just to help people find the fix.
FYI, when I performed the " One-Step Automated Install" on the freshly flashed Raspberry Pi OS Lite (64-bit) Bookworm, I didn't receive any errors and I didn't use the PIHOLE_SKIP_OS_CHECK workaround.

1 Like

"FYI, when I performed the " One-Step Automated Install" on the freshly flashed Raspberry Pi OS Lite (64-bit) Bookworm, I didn't receive any errors and I didn't use the PIHOLE_SKIP_OS_CHECK workaround." "

Same here today. on a Fresh Install. No errors. using

  1. wget -O basic-install.sh https://install.pi-hole.net
  2. sudo bash basic-install.sh

output from dig +short -t txt versions.pi-hole.net @ns1.pi-hole.net
"Raspbian=10,11 Ubuntu=20,22,23 Debian=10,11,12 Fedora=36,37,38 CentOS=8,9"

Thanks Pihole team for a quick fix. Hooray...