Pihole V6 is not working

My Pihole V6 is not working, i can not acces the web page (i assume that it still is ip adress/admin)
I am running on Debian 11, and my pihole says:
[i] Warning: You are using FTL from a custom branch (development-v6) and might be missing future releases.

After standard install i run theese commands:
echo "development-v6" | sudo tee /etc/pihole/ftlbranch
pihole checkout core development-v6
pihole checkout web development-v6

Did i do something wrong?
I am not using docker, i can not work with docker.

Try port 8080.


As noted in our beta 6.0 release notes: Pi-hole V6 Beta Testing – Pi-hole

The web admin GUI will be on port 8080.

Please Note: There is not currently any code in the installer/updater to remove/disable lighttpd or php, and it is unlikely that there will be – the last thing we want to do is squish peoples running webservers if they are using it for anything other than Pi-hole. You will need to remove/disable these yourself if you no longer need them

If lighttpd is still running on your system and listening on port 80, then FTL will start on port 8080 for http traffic. If you wish for it to be on port 80, or any other port, first stop/remove lighttpd and configure FTL’s listening port. For docker, do this with the environment variable FTLCONF_webserver_port

1 Like

If have no use for lighttpd and want to revert back to port 80.

Disable and stop lighttpd first (can apt purge later):

dehakkelaar@ph6b:~$ sudo systemctl disable --now lighttpd.service
Synchronizing state of lighttpd.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable lighttpd

Check current config:

dehakkelaar@ph6b:~$ sudo pihole-FTL --config webserver.port

Alter to port 80:

dehakkelaar@ph6b:~$ sudo pihole-FTL --config webserver.port '80,[::]:80,443s,[::]:443s'


dehakkelaar@ph6b:~$ sudo pihole restartdns
  [✓] Restarting DNS server


dehakkelaar@ph6b:~$ sudo ss -nltup | grep 'State\|lighttpd\|pihole-FTL'
Netid State  Recv-Q Send-Q Local Address:Port Peer Address:PortProcess
udp   UNCONN 0      0  *    users:(("pihole-FTL",pid=158551,fd=4))
udp   UNCONN 0      0               [::]:53           [::]:*    users:(("pihole-FTL",pid=158551,fd=6))
tcp   LISTEN 0      200*    users:(("pihole-FTL",pid=158551,fd=11))
tcp   LISTEN 0      32 *    users:(("pihole-FTL",pid=158551,fd=5))
tcp   LISTEN 0      200*    users:(("pihole-FTL",pid=158551,fd=13))
tcp   LISTEN 0      200             [::]:80           [::]:*    users:(("pihole-FTL",pid=158551,fd=12))
tcp   LISTEN 0      32              [::]:53           [::]:*    users:(("pihole-FTL",pid=158551,fd=7))
tcp   LISTEN 0      200             [::]:443          [::]:*    users:(("pihole-FTL",pid=158551,fd=14))

THANK YOU, finally had a chance to rebuild an aging office mini PC (6th generation intel i5, 16GB) now running Proxmox. Intending to deploy this at a remote location to host a network controller, needed something a little more powerful than a Raspberry Pi, this should be massive overkill for; UniFi Controller with Pi-hole + Wireguard VMs.

Actually shifted gears already, decided to start tinkering with LXC containers under Proxmox. Lots to learn, lots to learn -- just happy to be up and running with new v6 beta for the very first time, was a bit of a nagging issue trying to remove the default lighttpd stuff. Appreciate you making that super clear, it's way more convenient than having to rely on port 8080. You da man!

Appreciate all the hard work and dedication from the Dev team(s) and contributors. Vastly prefer Pi-hole over the other available options. Cannot imagine being online without network wide ad-blocking. <3

1 Like

Thanks for the feather :wink:
I also recently upgraded an old Intel NUC to become a baremetal/type 1 hypervisor.
I chose Xen over Proxmox because it can run very light paravirtualized Linux guests.
And guest/VM deployment is done via debootstrap directly from the APT sources from the net which can install a minimal (minbase) Debian/Ubuntu etc.
But the learning curve is a bit steeper (EDIT: OOTB no GUI).

dehakkelaar@xen02:~$ sudo xl list
Name                                        ID   Mem VCPUs      State   Time(s)
Domain-0                                     0 23100     4     r-----   83125.0
hak01                                        5  4096     2     -b----    3050.3
gam02                                        6  4096     2     -b----  234921.4
ph6b                                         9  1024     2     -b----   26228.5
dehakkelaar@xen02:~$ sudo xl uptime
Name                                ID Uptime
Domain-0                             0 22 days,  2:56:17
hak01                                5 22 days,  1:40:25
gam02                                6 22 days,  1:36:33
ph6b                                 9 22 days,  0:48:07
dehakkelaar@xen02:~$ sudo xl console ph6b
ph6b login:
1 Like

Oh and respect for the devs + contributors!
I experienced very little effort to find my way in v6.
EDIT: Without hardly reading any docs :wink:

interesting, XCP-ng has been on my radar for a minute (mostly thanks to Tom Lawrence), but have yet to actually tinker with it. Proxmox being Debian family (or literally Debian) makes it a bit more familiar, with the webgui to fall back on when i get myself in a jam.

These days i'm trying to ensure i'm not turning my SOHO network management into an additional full-time job, so simplicity is key. My lack of experience causes me to waste an awful lot of time on various projects. Pi-hole has remained tried and true for half a decade+ now. I've been through a bunch of iterations, both VMs and baremetal, now trying to rely on these little containers (LXC) from Proxmox. Was dead simple to get up and running, finally have the system deployed at the remote location which will hopefully be its final resting place. May need to invest in battery backup, or at least start tinkering with vPro to ensure i'm able to manage it remotely (including being able to power the device on/off in the event of a catastrophic failure).

Thanks again for the expertise and guidance. Much obliged! Happy holidays to all. Be safe.


Hello Harry. Have u had any issues with V6? Thinking about taking the leap but I have a compiled version of Unbound (19.0) and WireGuard configured so I don’t wanna muck things up.

If you want to keep your configuration and try v6 at the same time, my suggestion is to use a docker container.

1 Like

I still haven't really been using it -- at least not on my own network. I deployed a little (v6 beta) LXC Proxmox container on a remote host, but still using v5.17.3 on both of my LAN Pi-hole appliances.

Things seem decently stable, no issues importing my settings from the existing Pihole1 setup... I just created a checkpoint on my local Hyper-V host, considering taking the full plunge, but i want to test it (thoroughly) in my VM on the primary Pihole1 before i perform the upgrade on my RPi 3B+ which runs the Pihole2 appliance (and Wireguard).

I'll check back in once i finally make the leap. Thanks for all the hard work to Pi-hole Devs and community. Much obliged.

    Version is v5.17.1-269-ge1c41fe4 (Latest: null)
    Branch is development-v6
    Hash is e1c41fe4 (Latest: N/A)
    Version is v5.19-654-g32a1954b (Latest: null)
    Branch is development-v6
    Hash is 32a1954b (Latest: N/A)
    Version is vDev-1218151 (Latest: null)
    Branch is development-v6
    Hash is 1218151e (Latest: N/A)
1 Like