PiHole stats not working when installing using portainer

My pihole stats are not getting displayed at all

  1. Tried reinstalling. Still no difference.
  2. Cleared browser cache still no difference
  3. when using pihole -d command. stats gets updated for that particular min and then again no stats update

Note :
I have installed my pihole in portainer.

Looks like Pi-hole is working, but your devices are not using it.

Did you configure your router or your devices to use Pi-hole?

Please upload a debug log and post just the token URL that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

  • Yes, my pihole is working and my devices are using it.
  • Yes i have already configure my pihole in my router. but still i am not getting any stats update.

Debug token is: https://tricorder.pi-hole.net/tCJBk9AD/


Can anyone please help me. I am tying to fix it from long time.

It is hard to debug without all the information.

Please post the information about how you started your container:

  • Did you use a compose file (please post the file)?
  • Did you use a docker run command (post the command)?
  • Did you use only the Portainer web interface? We need details: which environment variables did you set? Are you using volumes or mounts (describe it)? Did you change any other option?
1 Like

I installed pihole by following the steps in the videos as mentioned
url: How to Install Pi-Hole on Docker with Portainer - YouTube

My installation process:

  • I have install my pihole as a container in portainer. And you can see all my pihole setting that i have put in portainer while installing in the below image

I didn't watch the video, but you are using the wrong port for DNS.

Looking at your screenshot, I see you set port 54:54.

This will point the host port 54 to the container port 54, but there is nothing in the container listening for port 54.

Inside the container only port 53 is used.
Also, how the devices will use Pi-hole if you set port 54? DNS uses port 53 by default.


Thank you so much. Now it is working. I changed my port to 53 and it is working properly now :slight_smile: