Pihole setup issues

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pihole blocks ads on all devices across local network and through vpn for remote blocking

Actual Behaviour:

Pihole only blocks on pi itself then disables internet access interfering with VNC server. Pihole uninstall terminal command does not uninstall. Pihole redirect page interferes with other servers running on local ip that have different ports than pihole. Nextcloud server update shows pihole admin redirect page.

Debug Token:


Let's take a look at these issues one at a time:

Your debug log shows that Pi-Hole is blocking both on it's loopback address and on it's external address. What specific problem are you seeing that leads you to the conclusion that Pi-Hole only blocks on Pi itself?

** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] ad.doubleclick.net.65617.9503.302br.net is via localhost (
[✓] ad.doubleclick.net.65617.9503.302br.net is via Pi-hole (
[✓] doubleclick.com is via a remote, public DNS server (

How is Pi-Hole interfering with VNC server? Please provide some specifics. Pi-Hole is not sharing any ports with VNC server nor blocking the VNC server port. Are you accessing VNC from outside your network?

What was not uninstalled? Did you elect to or not to remove dependencies?

Which Pi-Hole redirect page? Can your provide some more detail on these issue? Screen captures, logs, etc.

Yes give me a moment on the screen shots.The reason I have determined it is not blocking ads,is because it only blocks ads on the pi itself, If I pick up my laptop,watch on my roku,or use my iphone ads come in same as if pihole was off. When I set my pihole up as the only dns server in my rotuer shortly there after I lost the ability to make successful connections to webpages or services. Yes I routinely make remote access to my vnc server.

That is supposed to be my updater for my nextcloud and somehow it’s just a giant pihole logo with redirect to the admin page at the bottom

This is what happens when I try to uninstall pihole. It goes through apt-utils then stops and acts like nothing changed. I’ve always had to reinstall raspbian if I wanted to remove pihole

You can manually remove Pi-hole with :

sudo rm -rf /etc/.pihole /etc/pihole /opt/pihole /usr/bin/pihole-FTL /usr/local/bin/pihole /var/www/html/pihole /var/www/html/admin

I think one of your existing software that required http (apache from what I can see) might have got tangled with lighttpd and that's where the whole bad web interface experience originates from.

Apache seems to be running on port 81 where as lighttpd is on port 80.

This request:

went on port 80 and it hit lighttpd.

I think that path is availabe under apache.

Try it with

This indicates that the Pi-Hole is not receiving DNS requests from these devices and is not blocking any of their requested domains. With a second DNS in your router, clients will use that and bypass the Pi-Hole for some or all DNS requests.

Okay here’s what happened when I took Ramset’s suggestions. First I tested changing the port for nextcloud. It works for the most part as that is how I have been using it.It did not work for the updater as it just redirects me to the admin page instead of taking me to that redirect page which is what I took the screenshot of. That makes sense about the two services crossing do you have any suggestions on how to keep them separated? The removal command worked but now I don't have internet on the pi and it has knocked out my vnc server any suggestions on
that?JFB here is what happens with my netgear router and configuring its DNS. I have tried entering just
primary dns as the pi and every dns as the pi nowhere does it allow me to enter the /24 at the end of the address does this matter?I note that when I do this I lose internet on the pi and my vnc server. I have also tried entering on the devices themselves but ads come through anyway. Is another dns snuck in here somehow?

here is my router setup
here is what I see on mobile pihole testsite with pihole dns as only dns in my router

You could edit /etc/resolv.conf and specify a public DNS IP there (like google's or cloudfare's that will restore your connectivity.

Check out discussions in this post:

All you would need here would be the IP of Pi-hole.

One thing you need to make sure is that you set-up your Pi-hole installation to the correct interface (eth0) and from the admin interface, you set up the listening behavior (in your case ) to listen to all permit all origins.

That way both the LAN devices and VPN will go though Pi-hole.

Excellent man, thanks I really appreciate your time. Does it have to be eth0? I would perfer wlan0 and I know for the VPN the guide I follow https://docs.pi-hole.net/guides/vpn/installation/
they recommend tun0. Thanks for the article Im going to give that a try now.

I assumed you use the hardwired connection for it.

wlan0 works too as you will end-up setting the listening behavior to all ...

update editing /etc/resolv.conf did not work nor did editing /etc/dhcpcd.conf any other suggestion I’d perfer not to have to reinstall raspbian.

After some decent research I decided that reinstalling raspbian was much easier than figuring out how to fix the network error. I now have working pihole set on eth0 as only interface in the pi and my vpn adblocking by setting its dns to the pihole dns. I also have permit listing to all sources set . I decided to have my nextcloud server on a different pi so there would be no change of crossing over of software.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.