Pihole problem

I would disable DHCP on your router, and enable it on your Pi-hole.

Ok!I ve disabled the DHCP on my router.And enabled it on pi hole.Again,nslookup pi.hole returns nothing.
I also made the inner IP of the pi.hole as the DNS on my windows (to check it).Should I try something else??here are my dhcp settings and dns settings (on the router) just to check I m not making a silly mistake..sorry for keep asking but it drives my crazy..If we can't find a solution I ll leave it..

I suggest disabling IPv6 DHCP on your router as well. If this still does not work, as I suggested earlier, ssh into your Pi-hole and enter: pihole -d to run the diagnostics. Be sure to send the resultant token so that the Pi-hole developers can review the results and provide you with further assistance. I really can't help you at that level.

I ve just send them an email!!thanks so so much for your help!!

I ve tried to send the developers an e-mail at adblock@pi-hole.net.It returned not delivered..I also tried a personal e-mail with no response yet..I wish someone sees it so I could get in contact with them..

Please posrpr the token generated by

pihole -d

or do it through the Web interface:

Hello again!!it's https://tricorder.pi-hole.net/1uonkk400a

This is the place for contacting us. All the developers are here. Email is not a good way to get us involved.

For an unkown reason,when I click the token it says not available..Please,could someone verify that it's ok and you can view it??

Tokens expire after 48 hours.

So I should create another one here!Thanks so much!!
Ok,I just uploaded this: https://tricorder.pi-hole.net/bdh1pfze3p
BUT again,I get permission denied..Just verify that you can see it and it's only my problem..Thanks again!!

Only the developers have access to the logs, you will not be able to access that URL.

oh,that's why!!Thanks really..

Please,could a developer verify that you can see the token??should I create another one,or wait and create it tomorrow after it will expire??could I provide you info another way,without the expiration??

Why are you running a development version of FTL?

*** [ DIAGNOSING ]: Core version
[i] Core: v4.3.2 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Branch: master
[i] Commit: v4.3.2-0-ge41c4b5

*** [ DIAGNOSING ]: Web version
[i] Web: v4.3.2 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Branch: master
[i] Commit: v4.3.2-0-g38d8e77

*** [ DIAGNOSING ]: FTL version
[✓] FTL: vDev-c3ee98b (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)

Sorry if my answer is dummy..I just installed pi hole with the command:curl -sSL https://install.pi-hole.net | bash
I also tried to go to the beta version because it wasn't working..Should I uninstall and install again pihole??

Yes, you have a mix of versions on your system now.

OK!here is the new token,with the new installation..https://tricorder.pi-hole.net/c3n6zpoaz9
just to verify again..I go to the IPv4 section of my connection (lets say PC) and I enter to the DNS the address of my pihole.Then,nothing happens..

The debug log shows everything working without issues. What IP address are you entering? it's the IP shown in my router menu for raspberry pi.