PiHole on FreeBSD

FreeBSD isn't officially supported by pi-hole. This is a shame as its known to be a excellent OS for networking. I want to install pi-hole in a jail on TrueNAS 12, however I can't find any information about manually installing it on the docs.
Apart from setting up a webserver and sql or sqlite server, what php modules are needed for this to run ?
I sure with a LAMP stack and some config files pi-hole can work on FreeBSD, I don't see anything obvious that prevents it from working.
Could someone point me in the right direction to help get this setup ?
I will post a guide on how to do this if successful.
I cam across this Install on "non-supported" distro? - #8 by malbeth
however the links he posted to the install steps are no longer working :frowning:

There is an open feature request with some related discussion.

Thanks, ill post there.
Edit: Seems like its closed ? Not able to post anything there.

I just tested them and the attachments (txt files) & links are working fine...

Likely due to you being new to the forum. Hang out a bit and read some topics and you will be able to post there.

Thanks, tried again and it worked after showing a empty response error :upside_down_face:

Used @freqlabs github to build pi-ftl, it starts and listens on port 4117 and 53. Setup a caddy webserver to serve pi-admin files and copied pihoole to my bin directory.
I get a webpage with some errors about not being to open /proc/cpuinfo (which is fine) but it reports FTL service as not running. Does it check if the FTL file is in some path or just listening on port 4117 ? Maybe I missed some config file. Otherwise the web interface is working.

Progress ?? Oh and a divide by zero error, but that never hurt anyone right

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.