PiHole on a synology nas ignoring blacklist?


#1

My pihole seems to be ignoring the blacklist, and even some of my blocklists.

pihole -b pixfuture.net
::: pixfuture.net already exists in /etc/pihole/blacklist.txt, no need to add!
::: pixfuture.net does not exist in /etc/pihole/whitelist.txt, no need to remove!
::: pixfuture.net does not exist in /etc/dnsmasq.d/03-pihole-wildcard.conf, no need to remove!

And when querrying the blocklist in the webui.

::: /etc/pihole/list.7.www.fanboy.co.nz.domains (1 results)
||pixfuture.net^$third-party

::: /etc/pihole/list.preEventHorizon (2 results)
ax-d.pixfuture.net
||pixfuture.net^$third-party

::: /etc/pihole/blacklist.txt (2 results)
pixfuture.net
servedby.pixfuture.net

Yet its still resolving all querries to pixfuture.net & servedby.pixfuture.net

From the live output of the pihole.log file in the web ui.

Jun 8 22:54:02 dnsmasq[6201]: query[A] pixfuture.net from 192.168.1.186
Jun 8 22:54:02 dnsmasq[6201]: forwarded pixfuture.net to 208.67.222.222
Jun 8 22:54:02 dnsmasq[6201]: reply pixfuture.net is 192.99.101.101
Jun 8 22:54:02 dnsmasq[6201]: query[A] pixfuture.com from 192.168.1.186
Jun 8 22:54:02 dnsmasq[6201]: forwarded pixfuture.com to 208.67.222.222
Jun 8 22:54:02 dnsmasq[6201]: reply pixfuture.com is 192.99.101.101
Jun 8 22:54:02 dnsmasq[6201]: query[A] www.pixfuture.com from 192.168.1.186
Jun 8 22:54:02 dnsmasq[6201]: forwarded www.pixfuture.com to 208.67.222.222
Jun 8 22:54:02 dnsmasq[6201]: reply www.pixfuture.com is
Jun 8 22:54:02 dnsmasq[6201]: reply pixfuture.com is 192.99.101.101

Why is it still resolving the ip adresses for pixfuture?

Edit
So, one reinstall and two reboots later and now its actually blocking the domain.
I have no clue as to why it wasn’t doing it from the start, but hey. atleast it works.


#2

Possibly due to cache