Pihole Not Working on Other Devices using a ZyXEL router


#8

From second screenshot, change “Beginning IP address” into 192.168.1.10.
That leaves the lower 9 IP addresses to be assigned a static IP address.
From second screenshot, delete the second DNS server entry “DNS Server 2” (leave blank) or else, ads will still come through.
From third screenshot, leave as is or change back to default “Dynamic” DNS server.
Reboot your own PC.


#9

Yeah, I’m learning as I go as well. I’m not all that further ahead of you and still consider myself new to all this. I don’t have any additional ideas, just furthering on this one.

Verify that your connected devices IPs have changed to reflect the new IP range you entered. Since DHCP leases are timed, some of the old IPs may still be active. Especially make sure that no device BUT the pihole has the x.x.x.4 address.

Also, I doubt this makes a difference to this problem, but if you can’t completely eliminate that bogus x.x.x.5 address, I’d think about changing to something that doesn’t have even the potential for a conflict. For example, 10.x.x.x.


#10

It won’t let me leave it blank, so instead of put a b.s. ip address in their (10.1.1.1). For some reason it’s still not working though.


#11

Put in the same address twice.
So DNS1 and DNS2 point to Pi-Hole IP address 192.168.1.4.
Whenever you make DHCP changes, reboot your own PC or disconnect/reconnect network!!!


#12

It wont let me put in the same addresa twice. Thanks for the tip though.


#13

If your router wont allow, only alternative I can think of is switching the DHCP server off/disabling on the router.
And flip on the DHCP server on the Pi-Hole web admin page copying most of the settings from your router like start and end IP range etc.


#14

Yeah I tried that too. Unfortunately, that doesn’t work either. I have even tried connecting my phone and computer directly to the DNS on the pi, but the internet won’t work when I try that, so I’m not sure what the problem is.


#15

What is response from below on Pi-Hole ?

nslookup -type=a pi-hole.net
nslookup -type=a pi-hole.net 192.168.1.4

And what is response from below on the PC once it receives its IP from Pi-Hole instead of the router ?

nslookup -type=a pi.hole


#16

From pi-hole:
Server: 192.168.1.4
Address: 192.168.1.4#53

Non-authoritative answer:
Name: pi-hole.net
Address: 104.24.108.83
Name: pi-hole.net
Address: 104.24.109.83
From Mac:
Server: 192.168.1.1
Address: 192.168.1.1#53

** server can’t find pi.hole: NXDOMAIN


#17

Did you reboot the Mac after you switched DHCP server from router to that of Pi-Hole ?

This bit is wrong:

Server: 192.168.1.1

Should be:

Server: 192.168.1.4


#18

I just changed it manually in system preferences on my mac and get:
;; connection timed out; no servers could be reached


#20

That was it from my mac.


#21

Before you posted more info for the nslookup command :

Where has this info gone ?


#22

Above message makes me believe you configured network on mac manually and made a mistake.
Please try to set mac to receive IP via DHCP and reboot?


#23

I take back my previous post. I’m still getting this:
Server: 192.168.1.1
Address: 192.168.1.1#53

** server can’t find pi.hole: NXDOMAIN


#24

^ set to DHCP and reboot!


#25

I’m not sure how to do that. Could you please explain what I’m supposed to set?

should I be changing the LAN IP?


#26

Leave DHCP server disabled like on the screenshot.
Go to below link and lookup DHCP server and copy as many settings possible from the router web page:

http://192.168.1.4/admin/settings.php

And reboot PC !!!

EDIT: No dont change the static LAN IP address of the modem/router!


#27

Ps. if you dont min? I changed subject into below for others to find with similar issue:
“Pihole Not Working on Other Devices using a ZyXEL router”


#28

Not sure what all it is I should be changing here. The way that it is now is how I had it before.


and no problem.