Pihole is advertised to network but breaks internet

The issue I am facing:

Pihole is advertised to network but breaks internet

Details about my system:
Pi-Hole 5.0, Raspberry Pi 3 B+
What I have changed since installing Pi-hole:

Hi all,

I followed Section B , from this guide

I wondering why I am not getting internet when I just use Pi-Hole as DNS on my router, but when I add a secondary DNS on my router, everything is working normally (or is it....) .

Do i need to do anything else while following the guide from Pi-Hole Faq.

Please post the token generated by

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

When Rebooted, Pihole Cannot resolve anything without secondary DNS
[Router] ->[Pihole],[No Secondary DNS] ->No Internet

When Rebooted, Pihole resolves internet when there is a secondary DNS
[Router] ->[Pihiole][]-> Internet

Did I miss something from following the config from the guide.

From Tomato Router with googledns as secondary there is internet | If i removed google dns and restarted or release&renewed the whole network internet breaks:

From PiHole DNS settings:


I ditched using my router ip as custom Upstream DNS Server. And used Google(ECS) for upstream, PiHole IP is being advertised from all devices, no secondary(googledns) just in pihole, everything seems to be working fine, doesn't break the internet after reboots (took just a little while to comeback, but it works fine)


I set PiHole IP for primary. (Typo , it should be

Added these commands on my DNSMASQ
(Got the reference from this guide )


So it is working now?

I was wondering two aspects of your configuration:

  1. Do you really have a static IP assigned from you ISP on WAN for
  2. Your Gateway has which is outside of your subnet mask (see the additional 1)

Technically it is working.

  1. ISP(DHCP: is connected to routers wan(STATIC:
  2. Ah. that was a typo, was fidling my network during troubleshooting its supposed to be ::facepalm::

I noticed something really weird. When using GOOGLE(ECS), I find "Total Queries" increases really quick (like reeeeaaaallly quick.. in 10mins i have like 100k entries). So i flushed the pihole logs "pihole -f" , changed to cloudfare dns and Total Queries stops from increasing rapidly.

Any thoughts of this?

Think I unticked "Prevent DNS-rebind attacks" by accident, somehow it slows down the rapid increase of total queries. :upside_down_face:

Well I just gave up and set my Pi-Hole as DHCP server . As much as I want to make my tomato router as DHCP being protected is much better than none :slight_smile:
THank you.