Pihole GUI not updating stats

Hey guys, I´m new here and have a question:

Expected Behaviour:

-Updating the stats on GUI

Actual Behaviour:

All counters are set to 0
Total queries...etc

I found different solutions but nothing worked for me, including these:

Remove the line log-queries=extra from /etc/dnsmasq.d/01-pihole.conf

sudo service pihole-FTL restart

I tried to install php5-json but its installed.

I got the data directly from the API and everything is 0


Windows 10 (DNS entry (v4/v6) is pihole) and in the same local network.

Debug Token:


What is your Pi-hole version ? (pihole -v)
Your OS ? (cat /etc/os-release)

If you ping flurry.com (from the raspberry pi terminal) does it resolve into your Pi-hole IP ?

Pi-hole v3.3 and v3.3.1 are not supported on Jessie:

You have a few options:

  • Install or update to Raspbian Stretch
  • Update dnsmasq to a version > 2.72
  • Join the FTLDNS beta
  • Downgrade to an older version of Pi-hole

Thank for your help.

@Mcat12 Installing Debian Stretch was right and helps.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.