Pihole failing to resolve DNS

Please follow the below template, it will help us to help you!

Expected Behaviour:

Browsing to a site from a device on my wifi will load the page and block adds

Actual Behaviour:

Browsing to a site results in a “server IP address could not be found” error. I did not set up the pihole to work across my entire network (yet), but was just testing from a laptop by following the third set of instructions in this guide. After I do this setup my device does not show up as a client in the pihole admin console

Debug Token:

[Replace this text with the debug token provided from running pihole -d (or running the debug script through the web interface]

1 Like

Please upload a debug log and post the token here so we can look under the hood.

Also, what OS is your client laptop using? If Windows, then please post the output of ipconfig/all on that client.

See link below. I’m not sure if there will be anything helpful there as it seems like my laptop isn’t connecting to the pihole for DNS at all. I can ping the IP from my laptop and get a response, though

https://tricorder.pi-hole.net/8sj9gexy1g

From your debug log, some connectivity problems on your Pi - I’m only showing the IPv4 part but IPv6 has similar problems. Since there is no outward-facing IP address available, none of the clients can communicate with the Pi (and thus the Pi-Hole). Fix this problem and your Pi-Hole should work.

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway: 192.168.1.254
   * Pinging 192.168.1.254...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

    PIHOLE_INTERFACE=eth0
    IPV4_ADDRESS=192.168.1.64/24

ip addr may shed some light on the IP configuration of the Pi

Ok, I think I’ve fixed the connectivity issues. I’m now able to connect to pihole from my laptop, and I can log in to the admin portal & see I now have two clients. However, it doesn’t seem like my laptop is generating anything in the console–is there some other step I need to take for it to start actually blocking ads?

Nothing more should be required. Generate a new debug log and post the token.

Ok the internet issues actually weren’t resolved. I’m still able to connect to the admin console and SSH onto the pi, but it’s giving the IPV4 error in when I run debug. Do you know how I can resolve that? I have assigned it a static IP address–see screenshot from my router settings below

Output from my desktop from I run ipconfig/all
Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP-6D4G7JD
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : home

Ethernet adapter Ethernet:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Ethernet Connection (2) I219-V
Physical Address. . . . . . . . . : 30-5A-3A-57-B2-15
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
Physical Address. . . . . . . . . : 12-E3-27-12-8F-67
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 13:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
Physical Address. . . . . . . . . : 22-E3-27-12-8F-67
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : home
Description . . . . . . . . . . . : Qualcomm Atheros AR938x Wireless Network Adapter
Physical Address. . . . . . . . . : 60-E3-27-12-8F-67
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2a00:23c4:b416:5d00:cdbe:d1a0:ecff:ca7e(Preferred)
IPv6 Address. . . . . . . . . . . : fdaa:bbcc:ddee:0:cdbe:d1a0:ecff:ca7e(Preferred)
Temporary IPv6 Address. . . . . . : 2a00:23c4:b416:5d00:c542:6be4:1ab:2fb2(Preferred)
Temporary IPv6 Address. . . . . . : fdaa:bbcc:ddee:0:c542:6be4:1ab:2fb2(Preferred)
Link-local IPv6 Address . . . . . : fe80::cdbe:d1a0:ecff:ca7e%4(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.65(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Saturday, June 8, 2019 6:05:22 PM
Lease Expires . . . . . . . . . . : Sunday, June 9, 2019 11:46:29 PM
Default Gateway . . . . . . . . . : fe80::da7d:7fff:fef2:e7c1%4
192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DHCPv6 IAID . . . . . . . . . . . : 476111655
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-4E-83-94-30-5A-3A-57-B2-15
DNS Servers . . . . . . . . . . . : 192.168.1.64
NetBIOS over Tcpip. . . . . . . . : Enabled
Connection-specific DNS Suffix Search List :
home

Here’s a screenshot of the admin console taken from my desktop just to show it is loading and shows the now 3 connected devices

Check the output of these and see if the expected clients are connecting:

echo ">top-clients" | nc 127.0.0.1 4711

echo ">top-domains" | nc 127.0.0.1 4711

Ok, I did a complete de-install and re-install of pihole and got it to finally work :slight_smile: I think what happened is when I was initially setting it up I was using wifi and later switched to ethernet. Running either of the reconfiguration options was not fixing whatever issue that introduced, but totally removing it and re-installing seems to have done the trick!

Final issue… now when I browse to the admin console from my desktop (which worked previously) I’m getting a 403 - Forbidden error. Any thoughts on what’s contributing to that? Copied the error log below

https://tricorder.pi-hole.net/qohag7p5j8

Ok, so after I reboot the pihole the IPV4 error comes back. Is that a sign that my IP is not actually giving me a static address? Or is there something else I can do to prevent this from happening?

Check the IP configuration of the Pi with this Linux command:

ip addr

This is the output for that before I reboot, when the error is not there:
https://tricorder.pi-hole.net/saeh8e8ocg

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:ed:a5:13 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.64/24 brd 192.168.1.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 2a00:23c4:b416:5d00:46a4:229:1320:3da4/64 scope global mngtmpaddr noprefixroute dynamic
       valid_lft 21474830sec preferred_lft 21474830sec
    inet6 fdaa:bbcc:ddee:0:f130:d1a1:4b04:1da2/64 scope global mngtmpaddr noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::ad5:b6bc:2e8a:1478/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:b8:f0:46 brd ff:ff:ff:ff:ff:ff
    inet6 2a00:23c4:b416:5d00:6e6:708b:48fe:ccca/64 scope global mngtmpaddr noprefixroute dynamic
       valid_lft 21474831sec preferred_lft 21474831sec
    inet6 fdaa:bbcc:ddee:0:ca2d:d460:f2f9:72b4/64 scope global mngtmpaddr noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::8bb:9844:7d15:7bc0/64 scope link
       valid_lft forever preferred_lft forever

And this is the output after I reboot when the IPv4 error is there:
https://tricorder.pi-hole.net/ubherd08l7

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:ed:a5:13 brd ff:ff:ff:ff:ff:ff
    inet6 2a00:23c4:b416:5d00:46a4:229:1320:3da4/64 scope global mngtmpaddr noprefixroute dynamic
       valid_lft 21474829sec preferred_lft 21474829sec
    inet6 fdaa:bbcc:ddee:0:f130:d1a1:4b04:1da2/64 scope global mngtmpaddr noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::ad5:b6bc:2e8a:1478/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:b8:f0:46 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.64/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 2a00:23c4:b416:5d00:6e6:708b:48fe:ccca/64 scope global mngtmpaddr noprefixroute dynamic
       valid_lft 21474829sec preferred_lft 21474829sec
    inet6 fdaa:bbcc:ddee:0:ca2d:d460:f2f9:72b4/64 scope global mngtmpaddr noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::8bb:9844:7d15:7bc0/64 scope link
       valid_lft forever preferred_lft forever

When you reboot, your IP is reverting to WiFi. Disable the WiFi and ensure that MAC address is not in the router reservation. Then, run pihole -r and select reconfigure for the ethernet IP address.

Thanks, this fixed that issue! I couldn’t figure out what was going on with the admin page, but I figured something went wrong with the un-installs/installs, so I totally rebuilt the raspberry pi and re-did the pihole setup and that appears to have worked :slight_smile:

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.