Pihole causes need to reboot router several times a day, no internet

Debug token:
Token: bjiu5unten

Hardware, all brand new, no issues with old hardware.
Asus Ax-88u with Merlin firmware
Synology DS920+ with docker and pihole

Ive tried all kinds of settings, but most recently:

DNS filter on, router mode, no filtering
NAS with static ip
advitce router ip: No

Wan DNS Automatic
Forward local domain to upstream DNS: No

Pihole: 100% default.
Cloudfare DNS ticked, both of them
Server adress:
Router/ gateway

Everything on the NAS's network is "automatic" it gets the static IP from the Routers DHCP server.

Completely forgot to write what the actual problem was ! Sorry.
With this setup the internet simply drops after a few hours. often i cant even connect to the wifi og acces the router via cabled computer, nothing to do except rebooting the router.
At first i thought it was a DNS loop, but i think im over that, but its the exact same problem, the only thing that varies between my different tryouts is the time before it crashes, sometimes 3 hours, a single time i was lucky to get 2 days.

Really hope for your help, ive really enjoyed this product for the last couple of years and hate that it doesnt work, but im not much into all the verbs and have "average/basic" knowledge around networking, so pls bare with me,

I feel ive tried out every single guide and tip i could google, incuding a lot from this site, lots of them a tad old though :wink: so maybe outdated,

Thanks in advance !

Your debug log shows network connectivity issues, which appear to be unrelated to Pi-hole.

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway:
   * Pinging
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

But, shortly after this output, Pi-hole tested itself and is working properly.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] 5tysiecy.pl is via localhost (
[✓] 5tysiecy.pl is via Pi-hole (
[✓] doubleclick.com is via a remote, public DNS server (

Your problem is likely in your network.

so what would your advice be ? reset router with stock firmware? Or does your experience/ knowledge tell you that merlin is needed to make it work ?

Ive tried every single setting variation in the router.
On my way to work, write tomorrow :slight_smile: think ill start over on the router tomorrow.
can you confirm that pihole works ? and that i can take my eyes off of that ?

Your debug log indicates that Pi-hole is working.

I have no advice, since I don't use that router or Merlin firmware.

Would you be running Pi-hole inside a Docker container on your NAS?

If so, network related reports from the debug log may be inconclusive.
Since name resolution tests returned ok, your issue may not be related to your Pi-hole's IP.

Your debug log is showing your router is distributing itself alongside Pi-hole as DNS server:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers


This would allow clients to by-pass Pi-hole using your router for DNS.
Pi-hole should be the sole DNS server for your network.

It could also be related to your problem if your router wouldn't be able to retrieve DNS answers for some reason. One such reason would be a DNS loop.
However, your debug log doesn't show your Pi-hole to be using your router as upstream or for Conditional Fowarding, so that's not likely.

During such an outage, did you check DNS resolution?
E.g. by running the following commands from a client in your network, assuming would still be your Pi-hole machine's IP:

nslookup pi.hole
nslookup flurry.com

Yes it runs inside a docker :slight_smile:

Sorry, forgot to change that before the debug log, heres a fresh log with Router distributing itself off
Forgot to mention that is outside of DHCP range which is between 2-100, not that it helps anything regardless of that setting :slight_smile:
Token: abm7sxeswk

C:\Users\mprei>nslookup pi.hole
Server: pihole-pihole1

Name: pi.hole

C:\Users\mprei>nslookup flurry.com
Server: pihole-pihole1

Name: flurry.com
Addresses: ::

Did one with google:
C:\Users\mprei>nslookup google.com
Server: pihole-pihole1

Non-authoritative answer:
Name: google.com
Addresses: 2a00:1450:4005:80a::200e

Another thing i fell upon when google last night at work :stuck_out_tongue:
Was that maybe the modem which is in bridgemode could be an issue? i have an unfamiliar ip on my wifi, but cant check the MAC adress without resetting it and accessing it. If that IP is the modem, could it be an issue?
"Disconnected" pihole since yesterday and no fallouts has occured. must be some sort of conflict between router and pihole ?

If those nslookups were indeed run during an outage as proposed, that would mean that Pi-hole would have been fully operational at that time, able to resolve its own name (pi.hole) and applying blocking ( as expected, which in turn would suggest that your observation would not be related to Pi-hole.

So for the last few days, i installed the original ASUS firmware, updated it to the recent version ofc. and left it with as Wan DNS and static IP for my Synology with pihole.
With stock firmware im not given the option to not advice router IP.

Left LAN dns blank so pi.hole wasnt active.

Worked well, no fallouts.

3-4 hours ago i "activated it" with my LAN Dns for my static synology IP.
WAN dns on router switched back to automatic, pihole now has the DNS server.

3 hours later, everything dies. just now.
Did an ns lookup:

C:\Users\mprei>nslookup pi.hole
Server:  UnKnown
Address:  fec0:0:0:ffff::1

*** UnKnown can't find pi.hole: No response from server

C:\Users\mprei>nslookup google.com
Server:  UnKnown

*** UnKnown can't find google.com: No response from server


Ive just restarted the docker container, net and everything, set LAN dns for my SYnology.
im gonna wait for it to break, make a new debug log and and new Nslookup.

This is what it shows now with everything refreshed:

Debug Token: https://tricorder.pi-hole.net/60s7kce019

C:\Users\mprei>nslookup pi.hole
Server:  pihole-pihole1

Name:    pi.hole

C:\Users\mprei>nslookup flurry.com
Server:  pihole-pihole1

Name:    flurry.com
Addresses:  ::

C:\Users\mprei>nslookup google.com
Server:  pihole-pihole1

Non-authoritative answer:
Name:    google.com
Addresses:  2a00:1450:4005:80a::200e

This shows up in the terminal, no idea if its useful?

I gave up, something must be wrong with the asus router, im on my modem now and everything is healthy and alright, no disconnections, no bad signs from Synology or anything...
My VM disconnected from gateway every other hour, it doesnt anymore...

The symptoms sound very similar to: Pi-hole is crashing my ethernet network

Also a Pi-hole Docker container which leads to local network issues in hours. I've not really an idea what might cause it, after DNS loops and IPv6 have been ruled out. At least suggested checks/tests could be done vice versa and maybe comparing the setups helps identifying the underlying issue.

1 Like

Maybe so, but for now im 100% convinced my router is faulty, if the new one does the same ill update this post.

had an ac66u before this, everything went smooth for years, not 1 disconnect... new router, 4 disconnects a day... lol

Ah okay, I've overseen your last post it seems.

Even if the new router solves it, if enabled Pi-hole can be assured as trigger for the issue, it would be still interesting to find out what exactly makes that ASUS router crash :thinking:.

1 Like