PiHole and PIAware

Hi,

I figured out a (relatively simple) way to get PIHole and PiAware to work on the same box.
This was an issue that came up in this discussion Pi-hole and piaware - lighttpd? but that’s closed, and I can’t reply :frowning:

Simply create a new config file in /etc/lighttpd/conf-available/ called 87-dump1090-fa-documentroot.conf and set its contents to:

server.modules += ("mod_alias")

$SERVER["socket"] == "[::]:8080" {
  server.document-root = "/usr/share/dump1090-fa/html"
}

Create a symlink to this config file in /etc/lighttpd/conf-enabled/ with this command:

ln -s /etc/lighttpd/conf-available/87-dump1090-fa-documentroot.conf /etc/lighttpd/conf-enabled/87-dump1090-fa-documentroot.conf

then restart lighttpd (systemctl restart lighttpd) and enjoy your PiAware SkyView on port 8080 :slight_smile:

Note this seems to be a bug in PiAware’s way of creating the lighttpd files - they don’t set the documentroot in a config file, nor they ensure that the alias module is enabled. I want to report it to them, but right now GitHub is having some issues. I’ll do it tomorrow, provided I don’t forget.

6 Likes

@SoNic67 and @DanSchaper FYI, because you spent quite some time debugging this in the original post :slight_smile:
Happy PiAwareing!

4 Likes

You are a bloody legend.

My Pi is located 2000km away from me on a remote island.

I thought I had broken my precious PiAware setup by installing PiHole.

I thought I had to wipe the SD and reinstall PiAware. Given the Coronavirus lockdown, this was going to be impossible.

Your approach has been a miracle.

Thank you very much

2 Likes

A post was split to a new topic: Pi-Aware problems

Thank you!