Pi-hole Zugriff von unterwegs

Hallo zusammen,

auch ich bin komplett neu auf dem Gebiet und habe nun erfolgreich pihole auf meinem Raspberry pi 2 (iVm Fritzbox) eingerichtet.

Ich würde nun zusätzlich gerne über mein Smartphone auch außerhalb des Heimnetzwerks über mobile Daten auf mein pihole „zugreifen“ um so auch unterwegs von Werbung befreit zu sein.
Ich habe schon versucht über Google herauszufinden wie dies klappen könnte und es scheint ggf über pivpn oder openvpn möglich zu sein. Leider habe ich noch keine entsprechende Anleitung für mich als Anfänger gefunden.
Kann mir hier vielleicht jemand helfen? Bitte entschuldigt, falls es dieses Thema schon mehrfach gab. Ich habe nichts gefunden…

Vorab Danke für eure Hilfe…

https://docs.pi-hole.net/guides/vpn/overview/

Hallo,

du kannst deine Fritzbox auch als VPN Server einrichten und danach, wenn der VPN Zugang funkrtioniert, in den FB Settings unter Internet>Zugangsdaten>DNS Server deinen Raspi mit seiner IP eintragen.
Genauso habe ich das konfiguriert und es klappt einwandfrei.

Würdest du uns erklären, wie dies funktioniert?
Die Fritzbox als VPN Zugang habe ich bereits konfiguriert.
Aber den Raspi noch freigeben?

Danke, das hatte ich bereits gefunden. Der Link zur Kombination mit pihole ist leider aber dann tot.

Die Einstellung ist wg pihole dort ja ohnehin schon drin.
Ok, dann schonmal vielen Dank. Das werde ich heute Abend testen.

Hat er doch eigentlich bereits. „ in den FB Settings unter Internet>Zugangsdaten>DNS Server deinen Raspi mit seiner IP eintragen.“

Hi,

es gibt 2 Einstellung in der Ffritzbox zum Thema DNS IP.
Einige User schmeissen da auch gerne was durcheinander…

Internet>Zugangsdaten>DNS Server
Diese Einstellung wirkt sich auf den Zugriff von außen aus - also zB VPN und Gäste-WLAN

Heimnetz>Netzwerk>Netzwerkeinstellungen>IPv4Adressen
Diese Einstellung ist für das Heimnetzwerk - also die wichtigste von beiden!

Hab’s bei beiden Punkten drin. Danke für deine Mühe :+1:

Das lässt sich noch präzisieren:

Internet>Zugangsdaten>DNS Server

Dies sind die Upstream-DNS-Server, die die FritzBox zur Auflösung von DNS-Anfragen verwendet, wenn von anderen Geräten DNS-Anfragen an sie gerichtet werden (klicken für mehr).

Es sind damit auch die im Auslieferungszustand standardmässig verwendeten DNS-Server, da die FritzBox sich selbst als lokalen DNS-Server im Heimnetz ausgibt.

Trägt man hier Pi-hole ein, so kann es zu einer Endlosschleife kommen, wenn im Pi-hole wiederum die Fritzbox als Upstream-Server eingetragen ist. Außerdem muss bei dieser Konfiguration u.U. Pi-hole vom DNS-Rebind-Schutz der FritzBox ausgenommen werden.

Stehen neben Pi-hole noch andere DNS-Server in der Liste, wird die FritzBox DNS-Anfragen nach eigenem Ermessen auch an diese DNS-Server verteilen. Damit werden DNS-Anfragen dann nur teilweise gefiltert.


Heimnetz>Netzwerk>Netzwerkeinstellungen>IPv4Adressen

Dies ist der DNS-Server, den die FritzBox an über DHCP konfigurierte Geräte zur Verwendung als DNS-Server herausgibt (klicken für mehr).

Ein so konfiguriertes Gerät richtet seine DNS-Anfragen an diesen DNS-Server. Standardmässig gibt die FritzBox sich selbst als DNS-Server heraus.

Diese Einstellung wird nicht auf Geräten wirksam, die den DNS-Server manuell übersteuern oder ihre IP-Adresse nicht über DHCP beziehen.
Letzteres ist z.B. vielfach bei IPv6-Geräten der Fall, da hier die Konfiguration über Stateful DHCPv6 nicht vom Router erzwungen werden kann - vielmehr entscheidet das Betriebssytem der Geräte autonom, mit welchem Verfahren es seine Netzwerkeinstellungen ermittelt.

1 Like

Hast du ne Anleitung wie du deine FB als VPN eingerichtet hast? Ich habe es 1zu1 nach der Anleitung von AVM gemacht und die Daten im iPhone eingegeben. Wenn ich verbinden will bekomme ich immer den Fehler „ VPN-Server wurde nicht gefunden“ … und ja, wlan hatte ich vorher deaktiviert;)

Hab eben in der FB gesehen, dass dort steht diese sei nur über IPv6 erreichbar. Kann es sein, dass mein Mobilfunkanbieter nur IPv4 unterstützt und es daran liegt?
Wie ist das bei dir?

Edit: wieistmeineip.de hat mir verraten, dass ich nur IPv4 nutze. Dann kann ich VPN direkt mit der FB vergessen oder kennt da jemand ne Lösung?

Gibt es hierzu mittlerweile eine Lösung? Habe genau das gleiche Problem, dass ich keine Verbindung zur FB herstellen kann, obwohl exakt nach AVM Anleitung: VPN-Server wurde nicht gefunden.

Ich hab M-net. Wenn ich für die Option bezahle, dass ich nen richtigen IPv4 Zugang in der fritzbox bekomme (nicht nur ds Lite), dann sollte es mit VPN bestens funktionieren. Aktuell habe ich aber keine Lust dafür zu zahlen.

Hast du in den VPN-Einstellungen auf deinem iPhone Benutzername und Gruppenname ausgefüllt? Ist beide Male dein Benutzername wie unter System>FRITZ!Box-Benutzer angegeben.

Verstehe die Frage nicht so ganz. Hab doch zuvor beschrieben woran es liegt. :wink:

Failsafe and easy on a RPI, follow Marc Stan’s instructions.
Alles verschlüsselt!

Eben. Bei mir wurde auch permanent der Fehler ausgegeben, aber ich hatte nur eines der beiden Felder ausgefüllt. Danach ging’s.

@ForzaSGE: läuft der PiVPN bei Dir nun vollständig? Wollte Dir noch die Anleitung aus dem Kuketz-Blog mitgeben, nach der hab ich damals mein Pi-hole/PiVPN Setup aufgesetzt - finde das eigentlich die beste deutschsprachige Anleitung hierfür. Kennst Du den Artikel? https://www.kuketz-blog.de/pivpn-raspberry-pi-mit-openvpn-raspberry-pi-teil3/

Danke, ja diese Anleitung hatte ich damals gelesen, es war mir aber etwas zu kompliziert da ich erst in die Materie eingestiegen bin. Wollte es dann direkt über die fritzbox lösen, bin aber am oben beschriebenen Problem gescheitert.

@the_oestricher Danke für den Hinweis, ich bin aber der Meinung, dass ich das damals beides ausgefüllt hatte. Hab es genau nach Anleitung gemacht und auch ein Tutorial dazu geschaut. Bin mir ziemlich sicher, dass es nicht klappt weil ich drillisch (O2-Netz) als Mobilfunknetz habe. Die haben noch ausschließlich IPv4. Was ist dein Netz? Vodafone? Die haben ja vor kurzem IPv6 eingeführt. Telekom hat es schon länger…