Pi-Hole Webpages no longer load

Hi,
I have been using Pi-hole on a dedicated SBC (Orange Pi Board) for nearly 3 years now. I have it setup protecting my entire home network, complete with DNS enabled etc. It has proven to be quite reliable to date. My issue now though is that last week (around 5th October 2020) I did an update and reboot. Since then I have been completely unable to view the Pi-Hole webpages. I can still SSH into the system just fine, and it is running, however I just get a 404 error if I try to send a webpage request in the same manner I have done for years now. IE https://pi.hole/admin or my.ip.address/admin simply result in a page not found error.

I have looked online, but can find no assistance on this, apart from a very old Reddit discussion about this, that is years old. None of the suggestions there were relevant to my build.

I have followed the instructions in your template, which suggest the creation of a debug token. This I have done, and it is:
https://tricorder.pi-hole.net/nordc3njcc

Any assistance would be appreciated, thank you.

Your debug log shows your lighttpd web server is not running:

*** [ DIAGNOSING ]: Pi-hole processes
[✗] lighttpd daemon is failed

You may test your lighttpd installation for syntactical correctness by running:

lighttpd -t -f /etc/lighttpd/lighttpd.conf

If that comes back with Syntax OK, try restarting it:

sudo service lighttpd restart

In case that fails, please provide the output for:

sudo systemctl status --full --no-pager lighttpd.service

All above commands need to be run on your Pi-hole machine.

EDIT:
Since you are running on Orange Pi, probably also check your ramlog ownerships as mentioned in Cannot access web interface.

When I ran the first command, I appear to have some errors regarding the inability to change locale. See image below. I know a very long time ago I had problems with that .utf8 setting, though I can't remember what I did to fix it, or whether it's the same problem that's reared it's ugly head. With that said, I never had this problem before, where I am unable to access the webpages.

image

Run the command:

sudo dpkg-reconfigure locales

And set it to the locale you'd like, let it build the locale files.

Hi DanSchaper,
ok, I got my required locales updated by following the advice found here:

I appear to have the locales setup just fine now, but still no web page being served up.

I went through your earlier advice, and ran the commands again. This time, when I run:
lighttpd -t -f /etc/lighttpd/lighttpd.conf

I get told: Syntax OK
So far so good. I have also tried restarting the service as instructed, and also a full reboot, but no luck. I still have no webpage being served up

New debug token please.

You didn't provide output of the systemctl status command yet?
And did you check the advice on ramlog from the post I've linked?

Apologies, I hadn't noticed your request to run:

 sudo systemctl status --full --no-pager lighttpd.service
● lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2020-10-17 10:48:31 NZDT; 24h ago
  Process: 5173 ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf (code=exited, status=255)
  Process: 5160 ExecStartPre=/usr/sbin/lighttpd -t -f /etc/lighttpd/lighttpd.conf (code=exited, status=0/SUCCESS)
 Main PID: 5173 (code=exited, status=255)

Oct 17 10:48:30 Pi-hole systemd[1]: Starting Lighttpd Daemon...
Oct 17 10:48:31 Pi-hole lighttpd[5160]: Syntax OK
Oct 17 10:48:31 Pi-hole systemd[1]: Started Lighttpd Daemon.
Oct 17 10:48:31 Pi-hole lighttpd[5173]: 2020-10-17 10:48:31: (log.c.118) opening errorlog '/var/log/lighttpd/error.log' failed: Permission denied
Oct 17 10:48:31 Pi-hole systemd[1]: lighttpd.service: Main process exited, code=exited, status=255/n/a
Oct 17 10:48:32 Pi-hole systemd[1]: lighttpd.service: Unit entered failed state.
Oct 17 10:48:32 Pi-hole systemd[1]: lighttpd.service: Failed with result 'exit-code'.

Hi DanSchaper, as requested, a new token can be found here:
https://tricorder.pi-hole.net/h623bn8khq

Oct 17 10:48:31 Pi-hole lighttpd[5173]: 2020-10-17 10:48:31: (log.c.118) opening errorlog '/var/log/lighttpd/error.log' failed: Permission denied

That's the issue. I'm going to guess you have some sort of ram log and haven't set it to create the files that were there the last time lighttpd started. Or they have been created but with the wrong permissions. See Pi-Hole Webpages no longer load