pi-hole Weboberfläche - jetzt auf deutsch

Hallo in die Runde,

seit geraumer Zeit habe ich pi-hole bei mir am Laufen. Ein wirklich tolles Projekt. Ich bin sehr zufrieden. Auch habe ich in diesem Forum schon viel lernen können.

Leider halten sich meine Programmierkenntnisse in Grenzen, sodass ich an diesem Projekt nicht mitprogrammieren kann.

Um der Gemeinschaft trotzdem etwas zurückzugeben, habe ich versucht, die Weboberfläche auf deutsch zu übersetzen.

Das Projekt befindet sich nun https://github.com/pimanDE/translate2german, sodass es für jeden verfügbar ist.

Ich habe die Installation mehrfach durchlaufen, es sollten keine Fehler mehr enthalten sein.

Viel Spass damit :).

Gruss
pimanDE

5 Likes

Nette Idee, hat bei mir leider nicht funktioniert, weder über ssh noch über RemoteDesktop und Konsole.
pihole startet nach dem Versuch der Installation sehr langsam, hat anscheinend Probleme bei der Kommunikation zur Api.
Nach dem Rückkängig machen läuft wieder alles flüssig.

Hi,

danke für Deinen Test und die Rückmeldung.

Eigentlich sollte die Übersetzung keine Probleme bereiten, da hier nur “Begrifflichkeiten” ausgetauscht werden.

Einfach über ssh auf den pi aufschalten und dann die Installationshinweise ausführen.

Der pihole wird durch das Script weder angehalten, noch neu gestartet.

Bei mir hat es wunderbar (mehrfach) geklappt.

Gruss
pimanDE

Ich schrieb ja schon, dass es nicht über ssh funktioniert hat. Habe ich zuerst probiert. Nach der Installation habe ich pihole neu gestartet, hatte aber keine Auswirkungen ausser den beschriebenen.
Irgendwas hakt (bei mir)

hi, bei mir gibt es gar keine Änderung. Aber bei mir hängt nix und stürzt nix ab!:blush: (PS: Habe es auch über SSH installiert)

TinkerBoard
Armbian Bionic Kernel 5.3.13-rockchip

Hallo,

ich habe soeben nochmal ein frisches Raspbian aufgezogen, pihole installiert und dann die Übersetzung drüberlaufen lassen.

Keine Probleme.

Ist das Script denn durchgelaufen, oder gab es eine Fehlermeldung?

Gruss
pimanDE

Bei mir steht in grün “Erledigt.” und mit cat /tmp/error-translate.log wird nichts angezeigt. Also vermute ich mal, dass keine Fehler entstanden. Habe es nun auch ein zweites mal probiert und den Browser-cache gelöscht und neugestartet. Alles beim Alten.
Z.B. in /var/www/html/admin/index.php etc., dort sind noch überall die englischen Begriffe enthalten.

Hi,

Das ist schon mal gut. :+1:

Wenn Du das Speedtestmodul installiert hat, sollte hier auch nichts drin stehen, denn dann sind alle Begriffe gefunden und ausgetauscht worden.


Vielleicht magst Du ja mal folgendes ausprobieren:

sudo cp -r /var/www/html/admin /var/www/html/admin.sicherung.original

sudo rpl '<span>Dashboard</span>' '<span>Übersicht</span>' /var/www/html/admin/scripts/pi-hole/php/header.php

Nach drücken von F5 sollte anstatt “Dashboard” “Übersicht” stehen.

Gruss
pimanDE

rpl installier
Ü habe ich nicht in SSH hmmm mach ich UE draus…

$ sudo rpl ‘Dashboard’ ‘Uebersicht’ /var/www/html/admin/scripts/pi-hole/php/header.php
Replacing “Dashboard” with “Uebersicht” (case sensitive) (partial words matched)
.Traceback (most recent call last):
File “/usr/bin/rpl”, line 314, in
main()
File “/usr/bin/rpl”, line 246, in main
matches = blockrepl(f, o, regex, old_str, new_str, 1024)
File “/usr/bin/rpl”, line 92, in blockrepl
parts = (after.join(parts)).encode(encoding=encoding, errors=‘ignore’)
TypeError: encode() argument 1 must be str, not None

Browser anguck
F5 - refresh

keine Änderung. Ich weiß auch nicht was die obrige Fehlermeldung bedeutet.

Hallo,
das funktioniert wunderbar; ich musste in meiner Distro nur noch ein beherztes
sudo apt install rpl
eingeben; auf meinem SBC’s ist eine angepasste Version von Armbian installiert bei der dieser Befehl anscheinend fehlt (gefehlt hat :smiley: ).

Bis die Tage

ich habe nun noch mal probiert die *.sh Datei zu installieren nachdem ich rpl installiert habe. Dachte evtl. geht es ja somit. Allerdings, es dauert zwar länger bis “Erledigt.” steht. Die Error-Datei ist leer. Trotz Reboot leider keine Änderung! grübel
Das Speedtestmodul habe ich nicht installiert. Kenne ich nicht und kann es nicht installieren, weil der 2.Befehl in der Anleitung folgendes ausgibt.

sudo pip install speedtest-cli

The directory ‘/home//.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
The directory ‘/home//.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
Requirement already satisfied: speedtest-cli in /usr/local/lib/python2.7/dist-packages

speedtest ist nun installiert… ist sogar direkt auf der Pi-Hole Web-Oberfläche

Hi,

Danke für den Hinweis. Ich habe die Installationanleitung angepasst.

Das Speedtestmodul ist für die Übersetzung nicht nötig. Diejenigen, welche dieses Modul installiert haben, haben nun auch hierfür eine Weboberfläche ich deutsch.

Hast Du denn
sudo apt install rpl
ausgeführt?

Danach sollte es eigentlich klappen.

Gruss
pimanDE

habe ich auch gedacht. Also, ja habe rpl und auch Speedtest installiert. Habe also nochmal die *.sh Datei installiert und die Pi-Hole rebooted. Es ist immer noch alles beim Alten.
Was ich anmerken kann ist, dass ich meine Pi-Hole GUI erst erreiche, wenn ich LAN-IP/admin/settings.php im Browser eingebe, danach geht erst der Alias pi.hole … Also bei mir stimmt eh “irgendwas” nicht richtig und habe diesbezüglich einen neuen Thread für meinen Debug aufgemacht.
Vielleicht kann mir jemand im IRC/Discord helfen?

ich probierte: pihole -r (leider ist meine Blocklist nun um 700k Blocks geschrumpft-.-) Leider immer noch kein Glück.

Gerne; übrigens eine geniale Idee mit dem Script. Das lässt sich auch wunderbar und einfach an andere Sprachen anpassen.
Gruß

Also mir ist nun aufgefallen, dass in /var/www/html/pihole und /var/www/html/admin ganz viele leere .tmp.* Dateien sind.

Hi,

Vielen Dank. :slight_smile:



Da machst Du am besten ein eigenes Thema auf. Oder: frisches Image geladen und pihole neu installiert. Ist 'ne Sache von 20 Minuten. :wink:

Gruss
pimanDE

1 Like

Dafür ist das Forum hier nicht der richtige Ort. Für Probleme bitte den Issues-Bereich bei GitHub nutzen.

Da hast Du vollkommen Recht.

Mein Post bezog jedoch darauf, dass bei ihm grundsätzlich pihole nicht richtig funktioniert, hätte ich besser deklarieren sollen, sorry.

Gruss
pimanDE

1 Like

habe ich auch so verstanden, wie du meinst. ich probier morgen mal alles neu auf ein neues Gerät aufzusetzen. Allerdings, die leeren tmp-Dateien die durch dein Script entstehen. Kannst du in dein Script nochmal reinschauen, damit diese automatisch gelöscht werden?
Könntest du mir den Befehl nennen, damit ich alle diese tmp-Dateien aufeinmal über das Terminal manuell wieder löschen kann?

Habe auf deutsch umgestellt. Hat alles soweit funktioniert. Nur die Schreibweise der Zahlen stört mich noch (Tausendertrennzeichen+Dezimaltrennzeichen). Das sollte sich doch aber lösen lassen, oder?