Pi-hole version is v4.2.2 (Latest: v4.3.2) doesnt update

Please follow the below template, it will help us to help you!

Expected Behaviour:

Update Pihole subsystems to latest version

Actual Behaviour:

while reporting with pihole -up

[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] Web Interface: up to date
[i] FTL: up to date
[✓] Everything is up to date!
but…
Pi-hole version is v4.2.2 (Latest: v4.3.2)
AdminLTE version is v4.2 (Latest: v4.3.2)
FTL version is v4.3.1 (Latest: v4.3.1)

Debug Token:

https://tricorder.pi-hole.net/dehzw4fyk3

*** [ DIAGNOSING ]: Core version
[i] Core: v4.2.2 (How do I update Pi-hole?)
[i] Branch: master
[i] Commit: v4.2.2-0-gba1e94d

*** [ DIAGNOSING ]: Web version
[i] Web: v4.2 (How do I update Pi-hole?)
[i] Branch: master
[i] Commit: v4.2-0-g347994d

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v4.3.1

and I cant change the branch with pihole checkout core master, which results in…
[✗] Fetching branches from https://github.com/pi-hole/pi-hole.git

Try a pihole -r
pick repair

Tried that already, didn´t fix it…

Update Complete!

Current Pi-hole version is v4.2.2
Current AdminLTE version is v4.2
Current FTL version is v4.3.1

Sad that there is nothing I can do to fix it or that the community/devlopers come with ideas
… tried all options with
sudo git clone https://github.com/pi-hole/pi-hole.git /etc/.pihole
sudo git pull

nothing…

The community has not much to go on because we can’t see the debug log. Only support can have a look at it.

You have used a developer version (gba1e94d)

I searched on that and this should work:

https://discourse.pi-hole.net/t/error-dnsmasq-bad-option-at-line-44-of-etc-dnsmasq-d-01-pihole-conf/17905/2

You have the web interface on dev so better go to master:

sudo pihole checkout master

If that does not work then read on here:

https://discourse.pi-hole.net/t/cannot-update-ftl-to-latest-version/24381/3

@msatter thanks for replying.
I´ve tried the option to checkout for all, but… unfortunately no go

[i] Shortcut “master” detected - checking out master branches…
[i] Pi-hole core
[✗] Unable to pull Core master branch

then
sudo pihole checkout core master
[✗] Fetching branches from https://github.com/pi-hole/pi-hole.git
sudo pihole checkout web master
[✗] Fetching branches from https://github.com/pi-hole/AdminLTE.git

I have no clue how to fix the dev branch thingie, and uninstalling breaks my DNS resolving ofcourse. Hope someone from developing can help debug.

Try these steps to resolve the problem:

Run these commands for their output:

cd /etc/.pihole
git status
git rev-parse HEAD

Run these commands in the same directory to try and fetch the right tag:

git fetch --tags --force
pihole -v
pihole updatechecker local

Tried your commands @jfb ;

git status
On branch master
Your branch is up-to-date with ‘origin/master’.
nothing to commit, working tree clean

git rev-parse HEAD
ba1e94d3d9cf1894e0b5adca3e92738d21897568

sudo git fetch --tags --force
(no reply)

pihole -v
Pi-hole version is v4.2.2 (Latest: v4.3.2)
AdminLTE version is v4.2 (Latest: v4.3.2)
FTL version is v4.3.1 (Latest: v4.3.1)

pihole updatechecker local
(no reply)

any more ideas @jfb ? Uninstalling will render my dns resolving in err

As your Pihole is unistalled you replace 127.0.0.1 in /etc/resolv.conf with 8.8.8.8 so that you can still reach the Git to install Pihole.

Thanks… but while reinstalling…

[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u5
[✓] Disk space check
[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages… 2 updates available
[i] It is recommended to update your OS after installing the Pi-hole!

[i] Installer Dependency checks…
[✓] Checking for apt-utils
[✓] Checking for dialog
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[✓] Checking for git
[✓] Checking for iproute2
[✓] Checking for whiptail

[i] Using interface: enxb827eb9e93ae
[i] Using Cloudflare
[i] Static IP already configured
[i] Unable to find IPv6 ULA/GUA address, IPv6 adblocking will not be enabled
[i] IPv4 address: 172.16.11.230/24
[i] IPv6 address:
[i] Web Interface On
[i] Web Server On
[i] Logging On.
[✗] Check for existing repository in /etc/.pihole
[i] Clone https://github.com/pi-hole/pi-hole.git into /etc/.pihole…
Error: Could not update local repository. Contact support.

Found out during install with with curl -sSL https://install.pi-hole.net | bash -x (verbose) that GIT was failing to download the repository to /etc/.pihole

Solution:
Removed GIT from the raspberry APT, re-runned the install script which reinstalled GIT and it finally worked!

pihole -v
Pi-hole version is v4.3.2 (Latest: v4.3.2)
AdminLTE version is v4.3.2 (Latest: v4.3.2)
FTL version is v4.3.1 (Latest: v4.3.1)