Pi hole stops working after a few days

Please follow the below template, it will help us to help you!

If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using nginx instead of lighttpd, or there is some other aspect of your install that is customised) - please use the Community Help category.

Expected Behaviour:

Pi hole working any Time.

Actual Behaviour:

Hi there,

I set up pi-hole on a clean Raspberry setup. Everything works fine so far, but after a few days I don't have access to any URLs. Pi hole doesn't show any faults. Setting DNS away from pi hole in router settings will give internet access again.

What can I do? Please help

Debug Token:


Your debug log shows that Pi-hole is working normally:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] web-reco.searchmachinevisionnsweb-reco.marketing-ns.prod-cvs.net.zooplus.it is on lo (
[✓] web-reco.searchmachinevisionnsweb-reco.marketing-ns.prod-cvs.net.zooplus.it is on eth0 (
[✓] doubleclick.com is via a remote, public DNS server (

Let's take a look at the traffic volume Pi-hole is processing. Please post the output of this command from the Pi terminal:

echo ">stats >quit" | nc localhost 4711

This is not particularly high traffic volume, but your debug log shows a few periods when the upstream DNS server has not responded due to a burst of DNS traffic:

   -----tail of FTL.log------
   [2022-09-02 04:06:08.758 570M] Resizing "FTL-dns-cache" from 200704 to (12800 * 16) == 204800 (/dev/shm: 4.6MB used, 225.2MB total, FTL uses 4.6MB)
   [2022-09-02 07:27:04.752 570M] WARNING in dnsmasq core: Maximum number of concurrent DNS queries reached (max: 150)
   [2022-09-02 07:27:05.754 570M] SQLite3 message: database is locked in "INSERT INTO message (timestamp,type,message,blob1,blob2,blob3,blob4,blob5) VALUES ((cast(strftime('%s', 'now') as int)),?,?,?,?,?,?,?);" (5)
   [2022-09-02 07:27:05.755 570M] add_message(type=5, message=Maximum number of concurrent DNS queries reached (max: 150)) - SQL error prepare: database is locked

Is it possible to increase this queries limit or anything else I can do?

When the Limit is reached the whole internet access is blocked until I change the DNS server or restart pi hole

I would take a look at what client is making the volume of requests to hit this limit, and work from there.

echo ">top-clients (15) >quit" | nc localhost 4711

Here is the output, sorry I am really noob in this:

It looks like the majority of your DNS queries are coming from the Fritz Box IP, but they are unlikely to be originating with that device.

I do note that your DHCP server (the Fritz Box) appears to be passing out it's own IP for DNS, and not the IP of the Pi-hole:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   * Received 548 bytes from eth0:
     Offered IP address:
     Server IP address:
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      lease-time: 864000 ( 10d )
      renewal-time: 432000 ( 5d )
      rebinding-time: 756000 ( 8d 18h )
      domain-name: "fritz.box"
      Port Control Protocol (PCP) server:
   DHCP packets received on interface lo: 0
   DHCP packets received on interface eth0: 1

Is there anything I can do without using pi holes DHCP?

Instead of configuring your Fritzbox to use Pi-hole as upstream DNS server, did you consider to configure your Fritzbox to distribute Pi-hole's IPv4 as local DNS server instead of its own?

Also, you may want to go over Making your network take advantage of Pi-hole as well as Fritz!Box (EN) - Pi-hole documentation.

Thanks I will give it a try.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.