Pi-Hole not working with Bell 1000 router

Computer for Pi-Hole: An old Dell Inspiron 2650
O/S: Lubuntu 18.04
Static IP:

Network Router: Bell 1000 Router/modem (Sagemcom)
Router IP:
DNS Settings:
Domain name is not designated.

Browser error: Page not accessible
additional information from browser: DNS not set up correctly

Results: Can not access any internet web page. All local hardware is accessible by IP address.

If I change the router DNS settings back to Open DNS's servers, everything works again, but of course... no filtering.

If I manually address the Pi-Hole machine in a computer's DNS settings, it works fine.

Does anyone know how to fix this situation? I wanted for all machines to be filtered without having to set them all up manually - this is being used in a Motel, so it would be impossible to set every guest's machine manually.

Please send us the token generated by

pihole -d

or do it through the Web interface:

If I try it again at the Motel, we might have a guest revolt (pitch forks and torches) :wink: I've requested permission from the manager. Meanwhile, I have the same model modem here at my house, I will try and re-create the issue here.

Yup, does the same at my house... I will try the debug.

According to the log, Pi-Hole keeps reverting the gateway back to instead of I've changed this several times and it keeps coming back. Even after a pihole -r reconfigure.

What addresses are set in /etc/dhcpcd.conf for the interface?

it has two sections with the same name, one has the old settings when I did my trial run here at home, and the other with the Motel settings

interface enp2s1
        static ip_address=
        static routers=
        static domain_name_servers=
interface enp2s1
        static ip_address=
        static routers=
        static domain_name_servers=

I just tried changing those values to the correct ones. I re-booted, and the network status looks correct, but still no go. I've also lost my touchpad functionality again (stupid bug in Lubuntu) I need to re-install the drivers again.

Just remove the extra section that you don't need. There can only be one section in that file.

Here is the token: Your debug token is: https://tricorder.pi-hole.net/sofyn71n4k!

Note: I have to keep changing my DNS on my router back to a web DNS in order to post on this page.

I've just sent a support question to Sagemcom to see if there is something in the router to change.

Your Pi-Hole debug log doesn't show any problems. It can resolve DNS queries and communicate with the router.

Frustrating, because nothing on the network can access the internet as soon as I change the DNS settings in the router. I will try changing it again and power cycle everything on the network including the modem.

Try this to help your troubleshooting - instead of putting the entire network DNS on Pi-Hole, work with a single client with a manual DNS assignment to Pi-Hole. When you get that client working with Pi-Hole DNS, then expand the DNS to your router/network.

Power cycle didn't work...

Setting the DNS in my computer works fine...

I'm suspecting that they have built into the router that if a DNS address points internally, that it is either invalid, or it is searching an external source using that address and does not query internally.

Because I can access the internet through the Pi-Hole, but not through the router when I change the DNS to point to the Pi-Hole.

Look for something called either Rebind Protection or DNS Rebind. That will block DNS traffic from an internal address.

I don't see any visible options for Rebind Protection or DNS Rebind. They probably didn't allow for that feature to be customized.

You have established that the problem is not with the Pi-Hole. Have you considered getting another router to piggyback on your existing modem/router? You could put the existing router in bridge mode and let the new router do the routing.

Unfortunately I don't know if management will go for another purchase at the moment... (we updated the 24 port switches recently). I've e-mailed the manufacturer to see if they can offer a solution to fix the issue. Maybe an alternative firmware.

In the meantime, I'm going to check the "junk pile" for a working router... they grabbed some equipment from another motel that was being torn down.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.