Pi-hole not working on desktop


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

The pi-hole should be blocking ads on all devices with the DNS server set up.

Actual Behaviour:

Ads are being blocked on my iPhone SE and my laptop but not on my desktop (which is connected via cat6 ethernet). I have cleared my DNS cache on my desktop. I didn’t have to do that on my laptop or iPhone.

Debug Token:

eigg2hne3d


#2

What’s the output of these commands on your desktop? (assuming it’s Windows)

ipconfig /all
nslookup pi.hole
nslookup pi.hole 10.0.0.40

#3

Here is the output of ipconfig /all: https://pastebin.com/2bk2Atsr
And for the nslookups:

C:\Users\REPLACED>nslookup pi.hole
Server:  cdns01.comcast.net
Address:  2001:558:feed::1

*** cdns01.comcast.net can't find pi.hole: Non-existent domain

C:\Users\REPLACED>nslookup pi.hole 10.0.0.40
Server:  raspberrypi
Address:  10.0.0.40

DNS request timed out.
    timeout was 2 seconds.
Name:    pi.hole
Addresses:  2601:14e:4100:55b0:d7c5:521d:4113:2b4f
          10.0.0.40

I also forgot to mention earlier that going to 10.0.0.40 allows me to access the admin panel, but pi.hole doesn’t work at all.


#4

Your machine is not using Pi-hole, have you set the DNS server manually in your machine’s settings? If not, then try these commands to refresh your DHCP settings:

ipconfig /release
ipconfig /renew

#5

I have set the DNS server for both ethernet adapters (I use Evolve for gaming with my friends without port-forwarding) and refreshed the DHCP settings multiple times.


#6

What have you set the DNS servers to? Your ipconfig /all shows that you have more than just Pi-hole as DNS servers.


#7

I have the pi-hole (10.0.0.40) and the google DNS server as a backup (8.8.8.8). I don’t know what the IPv6 addresses are though, and I don’t know exactly how to or if I should remove them.


#8

You should remove all the DNS servers except Pi-hole. If you have more than one DNS server, your computer doesn’t have to use them in order (Ads might be resolved through your secondary instead of Pi-hole).


#9

Then why does it have me pick the Google DNS server?
PS: I can’t find the IPv6 addresses anywhere in my adapter settings.


#10

Pi-hole uses that as an upstream DNS server. Your DNS requests go through Pi-hole, get filtered, and non-ad requests go to the upstream servers.
Check the IPv6 adapter settings for IPv6 DNS server settings.


#11

None of my adapters have any DNS servers in them… That probably isn’t good… I also removed the Google DNS and it still won’t work.


#12

If they don’t have DNS servers, then you should click the option to use the DHCP provided ones. After doing that, send the new output of ipconfig /all


#13

For IPv4, IPv6 or both?


#14

Both IPv4 and IPv6 should be using DHCP (if the option is available).


#15

Would I be doing by choosing “Obtain DNS server address automatically?”


#16

Yes, that would be getting the DNS information from the DHCP server (automatically).


#17

Here is the results from ipconfig /all


#18

Have you set your DHCP server (usually the router) to use only Pi-hole? You may have to disable DHCP on your router and enable it on the Pi-hole.


#19

No I have not, and I don’t want to set it to use only the Pi-hole because not everyone on my network wants to use it.


#20

Then set the router to use it and manually set the DNS server on the devices you don’t want to use Pi-hole to something else. Or the other way around. Either way, Pi-hole can’t be used alongside another DNS server effectively.