Pi-hole not blocking ads; using DD-WRT router & VM


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi-hole blocks ads

Actual Behaviour:

I can visit any website very quickly, but Pi-hole does not block ads

Debug Token:

wdv2l3hb85

System:
Xubuntu 18.04.1 LTS running virtualbox. pihole is running on Ubuntu Server 18.04.2 in a VM in virtualbox (bridged adapter) and has a static IP from my router (DD-WRT).

For my router, I followed both Method 1 & Method 2 from this guide: How do I configure my devices to use Pi-hole as their DNS server? . I currently have Method 2 in my router.

My test page was this: https://ads-blocker.com/testing/ , but ads still show up.

Upon loading the pihole VM it goes straight to asking for the user login (pihole runs in background). Once logged in, if I use the “pihole status” command, I get the following:

sudo: unable to resolve host pihole1
[sudo] password for xxxx: *****
[green diamond] DNS service is running
[green diamond] Pi-Hole blocking is enabled


#2

Your debug log shows that your gravity list is empty. Rebuild gravity with pihole -g -f


#3

Thanks! That was it, solved!


closed #4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.