Pi-Hole is acting weirdly

Hello ,

Expected Behaviour:
Works ?
Not getting any errors while browsing

-operating system : Raspbian lite
-hardware : raspberry pi zero w
Connected by wifi
Pi-Hole with unbound: DHCP enabled
Router: DHCP enabled
I did this setup because my router don't allow the DNS server to be changed. And if I disable the DHCP from the router my tv-box don't work anymore

I followed this tutorial:

and this:

Actual Behavior:
My smartphone after browsing for 15/10 minute display: ERR_ADDRESS_UNREACHABLE or ERR_NAME_NOT_RESOLVED
It happens also to my laptop, but it's not as often as with my smartphone
Router DHCP config:

statics ip: (here my tvbox)

Pi-Hole DHCP config :

Debug Token:

Please consider my "networking skills" as very low

Sorry, can't access your Debug data, as I'm not part of the support team.

The issues you are seeing are not likely to be the pi-hole device itself.

All the devices that wish to use the pi-hole system need to be configured to use the pi-hole as their DNS server.

This can be configured manually in each device, or via properties sent by the DHCP server as part of setting up the connection. This is usually by far the best arrangement. Any other DNS server in the config is effectively a back door past the pihole's blocking function.

Also note that the way Pi-hole blocks access to undesirable sites is that when your client attempts to access a blocked site, that is it attempts to look up the IP address of one of the blocked sites, pi-hole returns an error claiming that the "blocked site" does not exist. So some of the "errors" you are seeing could be one of the sites you are accessing handing off a redirect to, say, an advertising site or tracking site in your blocklist, and pihole doing its job properly and blocking that site. Pihole depends on your client tidily handling that case, not always entirely successfully.

From the info above, it's not clear how your clients are getting their DNS config, which should be exclusively the Pi-hole server when inside your LAN.

So starting looking there would be profitable.

Some background questions:

What is the IP address of your pi-hole server?
Your smartphone seems to only have an IPV6 address as its DNS server "after the bug". Is this intentional on your part? Is your is your pihole and LAN configured to support IPV6? the router config does not suggest that it is.

What DNS server is your laptop set to use?

What os's are your smartphone and laptop running?

If your laptop is a windows system then "ipconfig /all" will tell you lots of useful information, including the DNS setup.

If its a Linux system then "cat /etc/resolv.conf" will get you started. Depending on the distribution, different DNS configurations are possible.

Cheers Harry

That IPV6 address maps to:
Reverse lookup of the IPV6 address

which looks like something stuffed in by your network supplier, and will need to be suppressed if you wish to use Pihole.


This is the expected result when pointing your browser at an URL for a domain that is blocked by Pi-hole, e.g. when accessing http://flurry.com.

If this happens for websites that you want to access, you may have to whitelist a domain.
The following topic may help with that:

Your debug log shows your Pi-hole to be operational for DNS via both IPv4 and IPv6.
You've also enabled Pi-hole's DHCP server, distributing its own IPv4 via DHCP with a 7 day lease time, while leaving IPv6 support disabled.

This will likely result in your Pi-hole being by-passed via IPv6, as your router may advertise itself as DNS server for IPv6.

To address this, you'd have to check whether you can disable IPv6 DNS in your router. Note that not all routers may support such an option.

I disabled IPV6 and DHCP on the router and everything works again (even my TVbox which was not supposed to work with the router dhcp turned off).

It seems not:

It only show IPV4 and not IPV6

Do you think I should enable DHCP IPv6 support on the pihole config page? Even if for the moment everything is working again?

Yes, I understand, but the devices facing the problem quoted in my first message simply could not connect to the Internet, only ping returned something, ping or ping google.com were unreachable.

Pi-hole's IPv6 support is only of secondary concern here.

The main thing is what shoka said:

As long as your router is pushing [2a01:<redacted>:73fc] as the IPv6 used for DNS (and judging by your debug log, that doesn't match your Pi-hole's IPv6 address), Pi-hole will be by-passed.

Enabling Pi-hole's IPv6 support would just add Pi-hole's IPv6 to the available IPv6 DNS servers - it won't stop your router from advertising its own.

You have to find a way to stop your router from distributing alternate IPv6 DNS servers.
You'd have to consult your router's documentation if and how that would be supported. (Note that these are not the upstream DNS settings for IPv4 from your screenshot).

That information should have been in your original post.

If you cannot ping Pi-hole's IP address, Pi-hole's host would have been inaccessible. And without that connectivity, your clients of course would have not been able to resolve any DNS request.

Fortunately, that seems to have been only temporarily, since you report it's working now.

Not anymore :sweat_smile:

I re-enabled dhcp on the router and set the range to
All the devices that are not working (on an interval of 10 to 15min)have an ip address set on the address range (so the addresses given by the dhcp of pihole) and all the devices that are working have an ip address set on the address range
If I disable the DHCP server of my router, all the devices lose access to the internet on an interval of 10 to 15min

Yup, my mistake

These are the DNS addresses that I can't change. My router don't allow it that's why Im enabling dhcp on pi-hole
according to this : What can I do if I can't change manually set the DNS server on my router?

I can't directly with this router. That's why I disabled ipv6 completely in the router settings and now it uses ipv4 dns address (but I'm not sure).

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.