pi-hole immer wieder nicht mehr nutzbar


#1

Hallo!
Ich habe pi-hole in einer Linux VM unter Debian 9 auf einem Windows 10 Host laufen, vorher hatte ich testweise einen Rock64 im Einsatz und in beiden Umgebungen das identische Problem dass nach einigen Stunden DNS Anfragen so lange benötigen dass die Seiten teilweise nicht mehr aufrufbar sind, Streams (z.B. Netflix) dann nicht mehr laufen und das suefen über die mobilen Geräte im Netz so gut wie nicht mehr möglich ist. Wenn ich per nslookup eine Adresse aufrufe dauert es bis zu 4 -5 Minuten bis eine Antwort kommt oder sogar ein “unspecified error”. Die Auslastung der VM ist dabei generell ziemlich niedrig, die des Windows 10 Hosts ebenfalls, im Livelog des pi-hole Webinterface kann ich nichts auffälliges feststellen allerdings sind meine Linux Kenntnisse eher rudimentär - ich bekomme dies nur behoben wenn ich die komplette VM einmal neu starte, dann läuft es wieder für meist einen halben Tag rund bis das Problem wieder losgeht und ich bin leicht am verzweifeln denn ich finde die Lösung an sich ziemlich genial - wenn ich auf einem Client als DNS die FRITZ!Box eintrage geht es sofort wieder flott wie gewohnt und in meiner Not abe ich nun alle 5 Stunden einen Reboot des pi-hole eingerichtet was natürlich keine Lösung auf Dauer ist! Bin für jede Hilfe dankbar, meine Frau jammrt schon rum weil sie nicht mehr netflixen kann…

Meine Umgebung:
pi-hole (aktuelle Version) VM mit einer vCPU & 2GB RAM

FRITZ!Box 7590 mit VDSL100 als DHCP Server, ph-hole als DNS eingetragen
pi-hole DNS Konfiiguration siehe Screenshots…!
pi-hole00|441x195


#2

Duplicate of Strange pi-hole problem after some hours


#3