Pi-hole extrem langsames surfen


#1

Hallo zusammen,

nachdem ich jetzt schon diverse Threads hier zu dem Thema gelesen habe und auch versucht habe die Lösungsvorschläge umzusetzen, benötige ich nun doch eure Hilfe.

Zunächst einmal meine Konfiguration:
– FritzBox 7490 mit VDSL 100 der deutschen Telekom (fungiert als Modem, Router und DHCP-Server)
– Raspberry Pi 3 mit Jessie Light und anschließender Installation von Pi-hole

Was habe ich wie Konfiguriert?
– Pi-hole besitzt eine feste IPv4 und eine feste IPv6 via ULA immer setzen.
– Pi-hole verwendet als DNS die IPv4 und IPv6 (ULA – fdXX:XXXX:…) der Fritzbox (als Upstream DNS)
– die setupVars.conf beinhaltet ebenfalls die korrekte IPv6
– im Pi-hole Webif unter dem Punkt Settings -> DNS sind alle Checkboxen unten deaktivert. (Custom DNS IPv4 und IPv6 sind aktiviert)
– die Fritzbox hingegen verwendet als lokalen DNS-Server die IPv4 und IPv6 des Pi-hole
– der Pi-hole verwendet aktuell nur die Standard Listen
– die IPv4 und IPv6 Tables wurden mit folgenden Befehlen erweitert:

iptables -A INPUT -p tcp --destination-port 443 -j REJECT --reject-with tcp-reset
iptables -A INPUT -p udp --destination-port 80 -j REJECT --reject-with icmp-port-unreachable
iptables -A INPUT -p udp --destination-port 443 -j REJECT --reject-with icmp-port-unreachable

ip6tables -A INPUT -p tcp --destination-port 443 -j REJECT --reject-with tcp-reset
ip6tables -A INPUT -p udp --destination-port 80 -j REJECT --reject-with icmp6-port-unreachable
ip6tables -A INPUT -p udp --destination-port 443 -j REJECT --reject-with icmp6-port-unreachable

Nun zu meinem Problem:
Diverse Seiten Internetseiten und Instagram antworten derartig langsam. Teilweise so, als wenn ein Time-Out der entsprechenden Internetseiten abgewartet werden. Leider hab ich noch nicht herausgefunden, wie ich die einzelnen Hops auswerten kann um zu sehen woran es liegt. Tendenziell vermute ich aber, dass das Problem am IPv6-Protokoll oder an HTTPS liegt. Sobald ich nämlich ausschließlich die DNS-Services (IPv4 und IPv6) von google verwende läuft alles schnell und sauber. Leider funktioniert dann die interne DNS-Auflösung meiner Netzwerkgeräte nicht mehr.

Hat jemand noch einen Tipp für mich, was ich noch prüfen könnte?

Vielen Dank!

Beste Grüße

Marc


#2

Also hier sollte zwar alles deaktiviert sein, aber als Custom IP die der Fritzbox stehen ( 4 und 6)


#3

– die Fritzbox hingegen verwendet als lokalen DNS-Server die IPv4 und IPv6 des Pi-hole

Ich staune, dass du bei diesem DNS-Ping-Pong überhaupt eine Adresse aufgelöst bekommst.


#4

Sorry, so ist es natürlich auch. Habe es oben abgeändert.

Das Routing sollte doch eigentlich wie folgt aussehen, oder nicht?
Client -> Pi-hole -> Fritzbox -> WWW

In Worten:
Der Client erhält von der Fritzbox per DHCP die Informationen über einen lokalen DNS-Server, in diesem Fall die Adressen vom Pi-hole. Die DNS Anfragen des Clients werden an die Pi-hole übermittelt, welcher die DNS filtert. Alle nicht geblockten Anfragen sollten doch dann an die Fritzbox übermittelt werden. Abschließend löst die Fritzbix die DNS mithilfe der ISP DNS auf.

Würdest du die Fritzbox in diesem Fall als DNS komplett ausschließen und die DNS Verwaltung ausschließlich über Pi-hole laufen lassen? Gibt es in diesem Fall einen Trick, wie ich dem Pi-hole meine lokalen DNS Namen beibringen kann? Beispiel: fritz.box & co?


#5

Nein, die FritzBox hat entweder den DNS Server des Anbieters oder z.B. diese:

und in den Netzwerkeinstellungen dann unter IPv4 und ipv6 den pi-hole als lokalen DNS einstellen:

So gibt die Fritzbox den Clients dien pi-hole als DNS bekannt. Diese fragen dann erst den pi-hole, dann die Fritzbox und diese dann den im ersten Screenshot eingetragenen DNS.

So läuft das bei mir absolut stabil und extrem flüssig (7590 mit VDSL 100, aktuell fast 60 Clients und einem Raspi 3 mit pi-hole)

Die Möglichkeit mit den lokalen DomainNamen mitzuteilen gibt es in der aktuellen Beta. Habe diese getestet bin aber wieder auf den Master zurück, da ich hier noch einige Fehler (aber auch einige Vorteile) hatte, mir aber ein funktionierendes System wichtiger war.


#6

So ist es bei mir ebenfalls konfiguriert. Bei den ISP Zugangsdaten der Fritzbox verwende ich die DNS-Adressen des ISP – das sollte in diesem Fall ja keinen Unterschied darstellen im Vergleich zu deinen alternativen Einträgen. Und in den Netzwerkeinstellungen ist als lokaler DNS-Server der Pi-hole angegeben – IPv4 und IPv6.

Mir wäre in diesem Fall ein stabiles System auch wichtiger. Von daher wäre ich noch über jeden Tipp oder jede Hilfe dankbar.


#7
  1. deaktiviere den DHCP-Server des Routers, trage als fall back einen externe DNS-Server im Router ein.
  2. kümmere Dich nicht um IPv6 (Deaktivieren in DHCP-Settings des Pihole), wenn Du IPv6-DNS-Auflösung nicht deziedierst brauchst (was in 99,9% der Fälle nicht nötig sein sollte)
  3. Aktivere DHCP-Server des Pihole, Gateway die IP-Adresse Deines Routers
  4. nutze auf dem Pihole einen beliebiebigen externen DNS-Forwarder

Client–>Pihole–>ext. DNS-Server

Der Router agiert rein transparent als Gateway mit IP4-NAT und spielt bei der Namensauflösung keine Rolle mehr


#8

schau mal in einem deiner Clients (Windows) z.B. mit ipconfig/all ob dort auch der pi-hole als DNS Server (sowohl ip4 als auch ip6) eingetragen ist.


#9

Also sowohl unter Windows 10 sind die DNS–Adressen richtig vom DHCP Server vermittelt worden.
Unter Mac OS X und iOS konnte ich dieses nur über die Systemeinstellung -> Netzwerk kontrollieren. Dort sind ebenfalls die Adressen korrekt eingetragen.
Was mir allerdings gestern Abend beim Testen noch aufgefallen ist, dass das Problem mit Windows 10 und dem Internet Explorer nicht vorhanden ist. Hier laden die Seiten wie Zum Beispiel: wetter.com, wetteronline.de heise.de echt flott. Hingegen brauchen diese Seiten unter Mac OS X und iOS mit Safari relativ lange. Mit Chrome unter Mac OS X ist es ein wenig schneller, aber im Vergleich zu Win 10 mit Internet Explorer nicht zu vergleichen.

Dem entsprechend vermute ich, dass das Problem nicht ganz beim Pi-hole liegt. Bleibt nur die Frage, woran es sonst liegen kann.


#10

Das Problem lässt sich beheben, wenn du in der Fritzbox ins Heimnetz -› Netzwerkeinstellungen gehst und nach unten scrollst bis du das siehst:
DNS-Rebind-Schutz
FRITZ!Box unterdrückt DNS-Antworten, die auf IP-Adressen im eigenen Heimnetz verweisen (DNS-Rebind-Schutz). Hier können Sie eine Liste von Domainnamen angeben, für die der DNS-Rebind-Schutz nicht gelten soll.

Domainnamen-Ausnahmen:
Hier die IP vom Raspberry eintagen.

Danach können dynamische Clients wie Chromecast Pi Hole als DNS Server finden und das Problem der langsam ladenden Seiten wird auch gelöst, da nicht auf IPv6 vergebens gesucht wird.


Pi-Hole und FritzBox Setup Anleitung