Pi-hole DNS not resolving

Hey ho,

So I have the following problem.

As soon as I have the Pihole IP set up as DNS Server on my desktop, no website is getting resolved anymore. I can access them via IP, but not via FQDN/Domain Name.

Entered its' IP in v4 and v6, also tried deactivating v6.

I can reach the admin interface via Domain when the DNS is set to automatic but only via IP when it's set to the Pihole IP.

pihole up shows:

::: Checking for updates...
::: Pi-hole Core: up to date
::: FTL: up to date
::: Web Interface: up to date
::: Everything is up to date!

pihole status shows:

::: DNS service is running
::: Pi-hole blocking is Enabled

Any idea on this case?

Greetings & Thanks in advance,

If there is no name resolution at all, it may be a gateway issue.

You should make sure your Pi-hole can reach the Internet.

You can also send us the token generated by

pihole -d

and we can take a look.

The Pi-hole can reach the internet.
Pinging e.g. google.com works and so does the web interface.

pihole -d gave me the token 3mch8pesyf .

I'm seeing several different issues in your log. Can you please run a pihole -r to repair your configuration? If that doesn't work, choose Reconfigure and make sure all the settings are correct for your network.

I've updated Ubuntu and done a full Reconfigure of Pi-hole, but I'm still getting the DNS error in my browser and I can still access sites via IP.
Done another debugging, token: gsxollrt86

What's the output of these commands:

head /var/log/pihole.log
head /etc/pihole/gravity.list
lsof -i -P -n | awk -F' ' '/LISTEN/ {print $9, $1}' | sort -n | uniq | cut -d':' -f2
netstat -tulpn

Feel free to sent this info to tricorder as well. You can save the output of the commands to a file and then send it to tricorder:

I've decided to use pastebin. Here are the outputs:

pihole.log: pihole.log - Pastebin.com
gravity.list: gravity.list - Pastebin.com
lsof: lsof - Pastebin.com
netstat: netstat - Pastebin.com

You have BIND installed, too? It may be conflicting with dnsmasq

Thanks, this fixed it.
I didn't even know that I had BIND installed, maybe it was preinstalled on the Image (it's an image from a webhoster) or installed with something else.

Uninstalled it and everything is running fine now :slight_smile:

1 Like

A post was split to a new topic: DNS not resolving