Pi-hole connected to the internet, but using manually setting the DNS on the router to the Pi-hole results in a "Bad Config" Error on Browser


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi-hole is blocking ads across all devices connected to the router

Actual Behaviour:

Pi-hole is connected to the internet, but opening browser results in DNS_PROBE_FINISHED_BAD_CONFIG

For the longest time I have not been able to get my pihole to work.

Let me give you some background: early on, if the DNS was specified manually on the router to have only the IP address of the Pi, no device could connect to the internet. I tried updating the pi and pinging 8.8.8.8 but would result in 100% packet loss. What I found when I typed in sudo route -n was that none of the gateways pointed to the IP address of the router. I then forced it onto the list by typing in sudo route add default gateway 192.168.x.x and now the pi could ping 8.8.8.8 and the pi was updated. However, this did not fix the problem and when connecting to the internet via the browser get a DNS_PROBE_FINISHED_BAD_CONFIG.

For reference, I tried following the instructions on this page but did not help me solve the issue Pi-Hole works on Pi, returns DNS_Probe_Finished_Bad_Config on desktop

My apologies if this is a repost but a search so far has found me no results that have fixed my issue. I am certain it is a configuration problem, if relevant, the devices used to connect to the internet are:

Windows 10 Chrome Browser
Android Chrome Browser

Sagemcom Fast 5260 is the router used

Debug Token:

piljedwih8


#2

You are running a fairly old version of Pi-Hole. Have you considered updating to the newer version? There are a number of improved features.

From the command line pihole -up should get you there.


#3

Thank you for the reply, I updated the pi-hole just now but unfortunately still giving me the same problems


#4

Please generate a new debug log and post the token. Thanks.


#5

You got it my friend, here is the debug token: sgm985ig7b


#6

This debug log shows your FTL still at version 3.0, but the Pi-Hole is working normally and blocking domains:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] true-tere-mexican-babe.blogspot.md is 192.168.1.180 via localhost (127.0.0.1)
[✓] true-tere-mexican-babe.blogspot.md is 192.168.1.180 via Pi-hole (192.168.1.180)
[✓] doubleclick.com is 172.217.14.110 via a remote, public DNS server (8.8.8.8)

From this, it appears the problem is in the router (most likely) or client configuration.


#7

Interesting, currently I do have the router set to manually specify the IP address to the 180 one. So I have these settings on the router:

Connection Type: DHCP
Manually set DNS
DNS1: (The 180 IP address, aka Pihole address)
DNS2: 176.103.130.130 (Adguard)

The same with the IPV6 address:
Manually set DNS
DNS1: (The pihole address)
DNS2: (None)

but what baffles me is that if I remove the adguard IP address devices no longer connect to the internet, and I get the BAD_CONFIG error. This seems to indicate that the adguard is what is blocking ads on the router, not the pihole.

Anything else I should look for on the router side that could be causing the problem?

Edit: Typo


#8

Having AdGuard as your second DNS allows traffic to bypass Pi-Hole and is not recoimended.

You may find success using the Pi-Hole as DHCP server.


#9

Thank you for the help, unfortunately I am back to square one it seems. I disabled DHCP on my router, enabled DHCP on my pihole per the instructions sent, and removed adguard from the DNS. The bad config error is still present on the browser.

Here is the new debug token: 3js603c1ld1


#10

A quick update: I managed to get FTL to update to 4.1.2, not sure it made a difference but here is the new debug token: fod9r6qxws


#11

You are on the latest version now. The new debug log shows that Pi-Hole is working normally:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] m.tixing51.net is 0.0.0.0 via localhost (127.0.0.1)
[✓] m.tixing51.net is 0.0.0.0 via Pi-hole (192.168.1.180)
[✓] doubleclick.com is 172.217.11.174 via a remote, public DNS server (8.8.8.8)

The problem apparently lies in your router (and possibly clients). After you make this DHCP server change, ensure you reboot the router, clear the DNS cache on the clients and renew the leases on the clients so they get the lease from the Pi-Hole. Additionally, I would clear the cache on that browser and ensure it isn’t using cached data.


#12

I am confused here, when it says disable the DHCP server on your router, do they mean this setting?


When I disabled this setting earlier, I could no longer edit the settings on the router and had to reset my router since I could no longer access the router IP address shown

Here is what I have for the DNS server:

Note that only the Pi-hole address is listed there. However, when this IP address is the only one listed, no internet connection across all devices, and a windows 10 troubleshoot points to the DNS:

Here is also the result of ipconfig /all on the windows 10 computer:

It still displays the router as the DNS server

On a side note, I noticed today when I typed in sudo route -n the 192.168.1.1 address was no longer on the list and had to relist it using sudo route add default gateway 192.168.1.1. Perhaps this might be an issue?


#13

Update: one of the windows computers on the network this morning had its dns server as the pihole as indicated in ipconfig /all but was giving the same problems, no internet on the device.


closed #14

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.