Pi-hole and Virgin MediaHub problem

I’ve installed pi-hole on my P3b+ as per the instructions, and it is working perfectly on the Rpi using chromium.

However, because I’m using a VirginMedia hub I can’t define pi-hole’s DNS server. I tried setting the DNS server address on my Mac, but then no internet page will load!

Apologies if this is a simple question / known solution. Best I could come up with searching the forums is that I need to buy a 3rd party router, but hopefully there’s a software based solution.

Debug token yr4wmdkhpa

Thanks!

You can use your Pi-Hole as the DHCP server:

Your debug log shows no IP addresses assigned to the Pi. Pi-Hole is listening on 192.168.0.22, but that is not the IP of the Pi. Check in your router settings and verify that the Pi has a reserved IP of 22.

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway: 192.168.0.1
   * Pinging 192.168.0.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

Thanks

I started by disabling my router DHCP server and enabling Pi-hole DHCP, but for some reason that stopped my Pi connecting. The Pi did have a reserved IP of 22. I ran the debug again and got lots of errors, so I reinstalled and ran debug - code is czcj6lw3aj

The debug is still saying the gateway didn’t respond. I used netstat -nr | grep default to confirm that the gateway is 192.168.0.01

The pi seems to be on 192.168.0.12 and the Hub has a reserved IP of 192.168.0.12/24

Thanks again for helping - sorry if the problem is my technical mistakes!

You have the same problem as before.

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway: 192.168.0.1
   * Pinging 192.168.0.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

I think it was me being stupid… I was connecting via wifi not ethernet so I reconfigured with wlan and now it works perfectly!

I’ve configured my devices to use the pi-hole DNS rather than using pi-hole as the DHCP - should I swap or does it not really matter if it works?

Thanks again

It is your preference. Some IOT devices don’t have configurable DNS settings - they take whatever DNS is provided during the DHCP handshake. If you have none of those and your current setup works, then stick with it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.