Pi-hole and OpenWrt setup (IPv6 issue?)

Hi, I have a fairly vanilla setup of Pi-hole on a RPi and OpenWrt on a router. I've set up OpenWrt using method 2 from How do I configure my devices to use Pi-hole as their DNS server?. However, ads are still not being filtered. Upon looking at the DNS servers of a client, I see the following entries

IPv4 DNS servers: <IPv4 address of pihole>
IPv6 DNS servers: <IPv6 address of router>

I suspect the second line is causing DNS resolution to go to the router instead of the pihole. How can I fix this? Thanks.

On your router, replace IPv6 address of router with IPv6 address of pihole or disable IPv6 altogether.

I was able to resolve this issue by unchecking "Local IPv6 DNS server" to prevent OpenWrt from announcing itself to the clients.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.