Only blocks for pi, can't get any other devices running

The issue I am facing:

I've read trough a lot of information and tried a few things, but i can't get other devices to use pihole, it only blocks for the pi itself. I have apache2 and lighttpd running at the same time and switched lighttpd port to 8080. I added my devices (notebook, phone) in pihole, they are in default group. I changed the DNS in the devices to the Pi's IP. I tried to read trough the debug log and find a reason, but i'm failing. For now, i don't want all devices on my network to use pihole, that's why i haven't changed anything in my router. I also tried to use apache2 instead of lighttpd for pihole, but failed.

My debug token:

Details about my system:

Raspberry Pi 4, Raspbian OS, Apache2 (Port 80, 443) and lighttpd (Port 8080) webservers running.
FritzBox 3490 router.

What I have changed since installing Pi-hole:

Changed lighttpd port, because 80 was blocked. Added my devices via group management.

Thanks in advance for any hints on what to try!

How do you make your devices use Pi-hole then?

Thanks for the quick response!

I added the Pi's IP as a DNS Server for my devices, as is described here (How do I configure my devices to use Pi-hole as their DNS server?) in Step 3. As alternate DNS Server (i use Windows) i chose or

Pi-hole has to be your sole DNS server.

If you provide any alternatives, your client may use that to by-pass Pi-hole.

In addition, you may have to add IPv6 DNS servers as well, lest your client may use IPv6 to by-pass Pi-hole.

Okay, i checked with the Pi's IP being my only DNS Server.

In Windows, i change it for IP4 and IP6 and that breaks my Internet connection:
DNS_PROBE_FINISHED_BAD_CONFIG when trying to reach a webpage.

On my android 10 smartphone i can only change IP4 to static, than edit IP Settings and change IP4 DNS. I can even put in the same ip for DNS1 and DNS2, it's compulsory to fill in both. That doesn't break my connection, but it also hasn't got any effect on pihole.

When i check my network overview, none of the other devices seem to use pihole, except for the pi itself.

It may take a reboot for Win10 to fully acknowledge your changes.
Did you try to reboot your Win10 machine after setting DNS manually?

If so, what do the following commands return from your Win10 machine?

nslookup pi.hole

If you cannot find a way to supply Pi-hole's IPv6 address as well, it's likely that your Androids will by-pass Pi-hole via IPv6 if it's available, especially since smartphones always prefer IPv6 over IPv4.

Yes, i tried rebooting, didn't change anything, still no internet access with the DNS set to Pi's IPs.

The commands return

  • pi.hole = non-existent domain (without DNS set)
  • pi.hole = DNS request timed out (with DNS set)
  • = some IP adresses (without DNS set)
  • = DNS request timed out (with DNS set)

My router only uses IP4 adresses in the network. My phone could only get an IP6 adress via mobile data, maybe that's why i can't edit IP6 Settings for Wifi.

Hi everybody,

anybody else got an idea what to do?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.