Nslookup: default server unknown

If I call nslookup on my PC I see

C:>nslookup google.de
Server: UnKnown
Address: 2001:16b8:5c46:a800:bc5e:75b1:c3f6:e2b5

Nicht autorisierende Antwort:
Name: google.de
Addresses: 2a00:1450:4001:825::2003
172.217.21.227

on pi hole server:

root@pi-server:/# vi /etc/hosts
root@pi-server:/# nslookup google.de
Server: 127.0.0.1
Address: 127.0.0.1#53

Non-authoritative answer:
Name: google.de
Address: 172.217.21.227
Name: google.de
Address: 2a00:1450:4001:825::2003

What I have to do, to fix this: Server: UnKnown

Regards,
Rafal

The nslookup on Windows is trying to use an IPv6 address for the DNS server and does not know the name for that IP address. Normally that would be pi.hole but without seeing the debug log I can’t tell if you have it configured correctly.

The nslookup on the Pi-hole is querying itself on the IPv4 loopback address and no reverse name lookup is performed in that case.

What kind of informations frm which log do you need?

C:\nslookup facebook.de
Server: UnKnown
Address: 2001:16b8:5c46:a800:bc5e:75b1:c3f6:e2b5

Nicht autorisierende Antwort:
Name: facebook.de
Addresses: 2a03:2880:f01c:20e:face:b00c:0:2
31.13.92.10

root@pi-server:/# tail -f /var/log/pihole*.log |grep facebook.de
Aug 12 21:44:22 dnsmasq[8233]: query[A] facebook.de.fritz.box from 2001:16b8:5c46:a800:f494:e7d3:ecdd:a0f4
Aug 12 21:44:22 dnsmasq[8233]: forwarded facebook.de.fritz.box to 208.67.220.220
Aug 12 21:44:24 dnsmasq[8233]: reply facebook.de.fritz.box is NXDOMAIN
Aug 12 21:44:24 dnsmasq[8233]: query[AAAA] facebook.de.fritz.box from 2001:16b8:5c46:a800:f494:e7d3:ecdd:a0f4
Aug 12 21:44:24 dnsmasq[8233]: forwarded facebook.de.fritz.box to 208.67.220.220
Aug 12 21:44:25 dnsmasq[8233]: reply facebook.de.fritz.box is NODATA-IPv6
Aug 12 21:44:25 dnsmasq[8233]: query[A] facebook.de from 2001:16b8:5c46:a800:f494:e7d3:ecdd:a0f4
Aug 12 21:44:25 dnsmasq[8233]: forwarded facebook.de to 208.67.220.220
Aug 12 21:44:25 dnsmasq[8233]: reply facebook.de is 31.13.92.10
Aug 12 21:44:25 dnsmasq[8233]: query[AAAA] facebook.de from 2001:16b8:5c46:a800:f494:e7d3:ecdd:a0f4
Aug 12 21:44:25 dnsmasq[8233]: forwarded facebook.de to 208.67.220.220
Aug 12 21:44:25 dnsmasq[8233]: reply facebook.de is 2a03:2880:f01c:20e:face:b00c:0:2

Every client in my network is usind pi-hole (pi-server.local in my configuration) for DNS.

In pi hole I configured “Upstream DNS Servers” back to my FritzBox.

You’ll need a reverse record for 2001:16b8:5c46:a800:bc5e:75b1:c3f6:e2b5 to resolve back to what you want it to display.

And how I should do this? And where?

Easiest would probably be to edit the /etc/hosts file to set that address to be the domain name you would like.

I added reverse entries for IPv6 and IPv6 in /etc/dnsmasq.d/01-pihole.conf. Than I restarted the server. And not I habe the problem, that:

The FTL service is offline!

I restarted it.

==> /var/log/pihole-FTL.log <==
[2019-08-12 22:37:34.683 1980] Using log file /var/log/pihole-FTL.log
[2019-08-12 22:37:34.684 1980] ########## FTL started! ##########
[2019-08-12 22:37:34.684 1980] FTL branch: master
[2019-08-12 22:37:34.684 1980] FTL version: v4.3.1
[2019-08-12 22:37:34.684 1980] FTL commit: b60d63f
[2019-08-12 22:37:34.684 1980] FTL date: 2019-05-25 21:37:26 +0200
[2019-08-12 22:37:34.684 1980] FTL user: pihole
[2019-08-12 22:37:34.684 1980] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2019-08-12 22:37:34.684 1980] SOCKET_LISTENING: only local
[2019-08-12 22:37:34.684 1980] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2019-08-12 22:37:34.684 1980] MAXDBDAYS: max age for stored queries is 365 days
[2019-08-12 22:37:34.684 1980] RESOLVE_IPV6: Resolve IPv6 addresses
[2019-08-12 22:37:34.684 1980] RESOLVE_IPV4: Resolve IPv4 addresses
[2019-08-12 22:37:34.684 1980] DBINTERVAL: saving to DB file every minute
[2019-08-12 22:37:34.685 1980] DBFILE: Using /etc/pihole/pihole-FTL.db
[2019-08-12 22:37:34.685 1980] MAXLOGAGE: Importing up to 24.0 hours of log data
[2019-08-12 22:37:34.685 1980] PRIVACYLEVEL: Set to 0
[2019-08-12 22:37:34.685 1980] IGNORE_LOCALHOST: Show queries from localhost
[2019-08-12 22:37:34.685 1980] BLOCKINGMODE: Null IPs for blocked domains
[2019-08-12 22:37:34.685 1980] ANALYZE_ONLY_A_AND_AAAA: Disabled. Analyzing all queries
[2019-08-12 22:37:34.685 1980] DBIMPORT: Importing history from database
[2019-08-12 22:37:34.685 1980] PIDFILE: Using /var/run/pihole-FTL.pid
[2019-08-12 22:37:34.685 1980] PORTFILE: Using /var/run/pihole-FTL.port
[2019-08-12 22:37:34.685 1980] SOCKETFILE: Using /var/run/pihole/FTL.sock
[2019-08-12 22:37:34.685 1980] WHITELISTFILE: Using /etc/pihole/whitelist.txt
[2019-08-12 22:37:34.685 1980] BLACKLISTFILE: Using /etc/pihole/black.list
[2019-08-12 22:37:34.685 1980] GRAVITYFILE: Using /etc/pihole/gravity.list
[2019-08-12 22:37:34.685 1980] REGEXLISTFILE: Using /etc/pihole/regex.list
[2019-08-12 22:37:34.685 1980] SETUPVARSFILE: Using /etc/pihole/setupVars.conf
[2019-08-12 22:37:34.685 1980] AUDITLISTFILE: Using /etc/pihole/auditlog.list
[2019-08-12 22:37:34.686 1980] MACVENDORDB: Using /etc/pihole/macvendor.db
[2019-08-12 22:37:34.686 1980] PARSE_ARP_CACHE: Active
[2019-08-12 22:37:34.686 1980] Finished config file parsing
[2019-08-12 22:37:34.688 1980] Database version is 3
[2019-08-12 22:37:34.688 1980] Database successfully initialized
[2019-08-12 22:37:34.688 1980] New forward server: 208.67.220.220 (0/512)
[2019-08-12 22:37:34.689 1980] New forward server: 208.67.222.222 (1/512)
[2019-08-12 22:37:34.699 1980] Resizing “/FTL-strings” from 4096 to 8192
[2019-08-12 22:37:34.723 1980] Resizing “/FTL-strings” from 8192 to 12288
[2019-08-12 22:37:34.731 1980] Resizing “/FTL-queries” from 196608 to 393216
[2019-08-12 22:37:34.738 1980] New forward server: 8.8.8.8 (2/512)
[2019-08-12 22:37:34.751 1980] Resizing “/FTL-strings” from 12288 to 16384
[2019-08-12 22:37:34.763 1980] New forward server: 8.8.4.4 (3/512)
[2019-08-12 22:37:34.774 1980] Resizing “/FTL-strings” from 16384 to 20480
[2019-08-12 22:37:34.818 1980] Resizing “/FTL-queries” from 393216 to 589824
[2019-08-12 22:37:34.939 1980] Resizing “/FTL-strings” from 20480 to 24576
[2019-08-12 22:37:34.948 1980] Resizing “/FTL-queries” from 589824 to 786432
[2019-08-12 22:37:34.997 1980] Resizing “/FTL-strings” from 24576 to 28672
[2019-08-12 22:37:35.033 1980] Resizing “/FTL-queries” from 786432 to 983040
[2019-08-12 22:37:35.046 1980] Resizing “/FTL-strings” from 28672 to 32768
[2019-08-12 22:37:35.132 1980] Resizing “/FTL-strings” from 32768 to 36864
[2019-08-12 22:37:35.133 1980] Resizing “/FTL-queries” from 983040 to 1179648
[2019-08-12 22:37:35.223 1980] Resizing “/FTL-queries” from 1179648 to 1376256
[2019-08-12 22:37:35.233 1980] New forward server: 192.168.178.1 (4/512)
[2019-08-12 22:37:35.296 1980] Resizing “/FTL-strings” from 36864 to 40960
[2019-08-12 22:37:35.321 1980] Resizing “/FTL-queries” from 1376256 to 1572864
[2019-08-12 22:37:35.422 1980] Resizing “/FTL-queries” from 1572864 to 1769472
[2019-08-12 22:37:35.476 1980] Imported 34901 queries from the long-term database
[2019-08-12 22:37:35.477 1980] -> Total DNS queries: 34901
[2019-08-12 22:37:35.477 1980] -> Cached DNS queries: 4531
[2019-08-12 22:37:35.477 1980] -> Forwarded DNS queries: 19035
[2019-08-12 22:37:35.477 1980] -> Exactly blocked DNS queries: 11334
[2019-08-12 22:37:35.477 1980] -> Unknown DNS queries: 1
[2019-08-12 22:37:35.477 1980] -> Unique domains: 1781
[2019-08-12 22:37:35.477 1980] -> Unique clients: 17
[2019-08-12 22:37:35.477 1980] -> Known forward destinations: 5
[2019-08-12 22:37:35.478 1980] Successfully accessed setupVars.conf

But it’s now working. The added entries are removed.

This looks ok:

ls -al /var/run/pihole
insgesamt 0
drwxr-xr-x 2 pihole pihole 40 Aug 12 22:19 .
drwxr-xr-x 28 root root 880 Aug 12 22:37 …

http://pi-server.local:8093/admin/api.php -> {“FTLnotrunning”:true}

The file you edited has a big warning at the top to not edit it:

cat /etc/dnsmasq.d/01-pihole.conf 
# Pi-hole: A black hole for Internet advertisements
# (c) 2017 Pi-hole, LLC (https://pi-hole.net)
# Network-wide ad blocking via your own hardware.
#
# Dnsmasq config for Pi-hole's FTLDNS
#
# This file is copyright under the latest version of the EUPL.
# Please see LICENSE file for your rights under this license.

###############################################################################
#      FILE AUTOMATICALLY POPULATED BY PI-HOLE INSTALL/UPDATE PROCEDURE.      #
# ANY CHANGES MADE TO THIS FILE AFTER INSTALL WILL BE LOST ON THE NEXT UPDATE #
#                                                                             #
#        IF YOU WISH TO CHANGE THE UPSTREAM SERVERS, CHANGE THEM IN:          #
#                      /etc/pihole/setupVars.conf                             #
#                                                                             #
#        ANY OTHER CHANGES SHOULD BE MADE IN A SEPARATE CONFIG FILE           #
#                    WITHIN /etc/dnsmasq.d/yourname.conf                      #
###############################################################################

We do not support installations that modify the web interface as you have moved it. Without a full debug log I can not assist you with your issues.

Try editing the /etc/hosts file with your domain names and reset the Pi-hole back to what it was previously with pihole -r.

Something is crashed. Cause the server ca’t get connection to the internet.

pihole -r wasn’t working.

[✓] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary…
[✗] Downloading and Installing FTL
Error: Unable to get latest release location from GitHub
[✗] FTL Engine not installed

root@pi-server:/# wget google.de
–2019-08-12 23:02:43-- http://google.de/
Auflösen des Hostnamens google.de (google.de)… fehlgeschlagen: Temporärer Fehler bei der Namensauflösung.
wget: Host-Adresse »google.de« kann nicht aufgelöst werden

@DL6ER Can you provide assistance with this?

2001: Is a public address with IPv6 and search for the fe80: adress of your Pi-hole and use that.

Thx for you help. But with my change in /etc/dnsmasq.d/01-pihole.conf I hat more problems

Result: new installation of the whole server. Now it works.