Not working on jessie after update, dnsmasq updated too


#1

Hi,

i am using a pihole for a while i recently updated to 3.3 and i have stopped it is not working any more. I have updated the dnsmasq as suggested but it is still the same. p

web ui is not updated not updated and I cannot see the ads are blocked. please see screenshot below

Debug Token:

x6f5b7vuox

can you please help me what needs to be done here?


#2

Can you try pihole -r > Repair?


#3

thanks for the suggestion however I forgot to mention that I have done this several times but no change. it is completing the repair just fine but nothing happens.


#4

So according to your log (and screenshot), Pi-hole is working, but you don’t seem to have any devices using it as their DNS server.


#5

Hi,
thank you for this but I do not think it is the problem as it was working fine before also all the settings are done properly. please see screens below.
image

when I tail the pihole.log. I can see entries coming to there as well.


#6

hi there,

I have tested on one of the test sites and I actually can confirm the pihole is working but it is web UI is not working.


#7

I’m very confused now since your previous screenshot showed the Web interface working?


#8

it is running but it is not updating the dashboard. I have flushed the logs and restarted the pi but no change. even after flushing it is showing the same as my screenshot also.

pihole -c gives the below
Pi-hole Chronometer

Press Ctrl-C to exit
——————————————————————————————————————————————————————————
Hostname: raspberrypi (Raspberry Pi 1, Model B)
Uptime: 00:02:33
Task Load: 0.79 0.56 0.23 (Active: 7 of 33 tasks)
CPU usage: 66% (700 MHz @ 322k)
RAM usage: 17% (Used: 73 MB of 434 MB)
HDD usage: 19% (Used: 1 GB of 7 GB)
LAN addr: 192.168.1.69 (Gateway: 192.168.1.1)
Pi-hole: Active (Blocking: 559465 sites)
Ads Today: 0% (Total: 0 of 81)
Local Qrys: 28% (2 DNS servers)
Blocked:
Top Advert:
Top Domain: ntp.readytoconnect.co.uk
Top Client: 192.168.1.1


#9

Which part of the graphs are not populating?


#10

no graphs or statics are updating.

the data is still the same since yesterday and I have checked the logs they are actually populated.


#11

Is it just the queries over time graph?


#12

no, it is all the reports from web interface.
query log, top lists all is not updating.

thanks for all the help


#13

i have uninstalled and installed the Pihole again and this has resolved the problem


#14

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.