Not blocking ADs


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Delete all AD’s and block the websites listed in blacklist only.

Actual Behaviour:

It never blocks ADs, for example this website (www.3sk.tv), you can see ads all over the webpage but when I use chrome extensions such as ADBlock or Ublock, they are removed. PiHole won’t remove the ADs for a lot of sites, and it just randomly blocks my access from a lot of websites, while I’m surfing the internet, to access the websites, I must keep adding the websites I want to access one by one in the whitelist. It’s annoying.

Debug Token:

::: Beginning Pi-hole debug at Tue Oct 24 20:03:03 UTC 2017!
:::
::: This process collects information from your Pi-hole, and optionally uploads
::: it to a unique and random directory on tricorder.pi-hole.net.
:::
::: NOTE: All log files auto-delete after 48 hours and ONLY the Pi-hole developers
::: can access your data via the given token. We have taken these extra steps to
::: secure your data and will work to further reduce any personal information gathered.
:::
::: Please read and note any issues, and follow any directions advised during this process.
:::
::: —= Detecting Installed Package Versions:
::: Pi-hole: v3.1.4 (master:v3.1.4-0-gb0ecedd)
::: Pi-hole Dashboard: v3.1 (master:v3.1-0-gf204b71)
::: lighttpd/1.4.45
::: PHP 7.0.19-1 (cli) (built: May 11 2017 14:04:47) ( NTS )
:::
::: —= Detecting existence of /etc/pihole/setupVars.conf:
::: File exists, parsing…done and was successfully sourced
:::
::: —= Detecting installed OS Distribution
:::
::: —= Checking processor variety
:::
::: —= Checking IPv6 Stack
::: IPv6 addresses located on eth0
::: No gateway detected.
:::
::: —= Checking IPv4 Stack
::: IPv4 addresses located on eth0
::: Pinging default IPv4 gateway: ::: Gateway responded.
::: Pinging Internet via IPv4: ::: Query responded.
:::
::: —= Daemon Process Information
::: Checking http port for lighttpd listener.
::: Correctly configured.
:::
::: —= Daemon Process Information
::: Checking domain port for dnsmasq listener.
::: Correctly configured.
:::
::: —= Daemon Process Information
::: Checking 4711 port for pihole-FTL listener.
::: Correctly configured.
:::
::: —= Processes Check
::: Logging status of lighttpd, dnsmasq and pihole-FTL…
:::
::: —= Resolver Functions Check (IPv4)
:::
::: —= Resolver Functions Check (IPv6)
::: Checking for necessary lighttpd files.
:::
::: —= Detecting existence of /etc/lighttpd/lighttpd.conf:
::: File exists, parsing…done
:::
::: —= Detecting existence of /var/log/lighttpd/error.log:
::: File exists, parsing…done
:::
:::
::: —= Detecting existence of /etc/dnsmasq.conf:
::: File exists, parsing…done
:::
::: —= Detecting contents of /etc/dnsmasq.d/*:
:::
::: —= File /etc/dnsmasq.d/01-pihole.conf found
::: Parsing…done
:::
::: —= File /etc/dnsmasq.d/README found
::: Parsing…done
:::
:::
::: —= Detecting existence of /etc/pihole/whitelist.txt:
::: File exists, parsing…done
:::
::: —= Detecting existence of /etc/pihole/blacklist.txt:
::: File exists, parsing…done
:::
::: —= Detecting existence of /etc/pihole/adlists.list:
::: File exists, parsing…done
:::
::: —= Analyzing gravity.list
:::
::: —= Analyzing pihole.log
:::
::: —= Analyzing pihole-FTL.log
:::
::: --= User Action Required =–
::: Try loading a site that you are having trouble with now from a client web browser…
::: (Press CTRL+C to finish logging.)
:::
::: —= pihole.log
::: Logging will automatically teminate in 60 seconds
::: 60 seconds left.
::: 55 seconds left.
::: 50 seconds left.
::: 45 seconds left.
::: 40 seconds left.
::: 35 seconds left.
::: 30 seconds left.
::: 25 seconds left.
::: 20 seconds left.
::: 15 seconds left.
::: 10 seconds left.
::: 5 seconds left.
::: Finshed debugging!
::: The debug log can be uploaded to tricorder.pi-hole.net for sharing with developers only.
::: Debug script running in automated mode, uploading log to tricorder…
::: —=== Your debug token is : z84mc0x1z2 Please make a note of it. ===—
::: Contact the Pi-hole team with your token for assistance.
::: Thank you.
::: A local copy of the Debug log can be found at : /var/log/pihole_debug.log


#2

Ok, I’m getting the same issue. I certainly don’t mean to hijack the tread, but since it’s not blocking ads on either, I thought I’d throw my debug token in as well.

n9xe0xbhrx

I’ve just moved my pi from one place to another (completely different residence).


#3

If you run Windows and AVAST this may help by @marcdraco63
https://discourse.pi-hole.net/t/thanks-for-nothing-microsoft/5226/12


#4

No Avast here for me. Just me & my Mac.


#5

I’m not running AVAST.


#6

Could you ask on a Mac discussion forums about DNS issues Linking https://pi-hole.net or explain what it does and blocks?

May I ask which Block Lists you are using?

The router configuration in important, see. You also have to reboot or renew IP leases on devices.


#7

I’m using this Block List:

If anyone can share their PiHole settings/Block Lists, I’ll appreciate it, would be very helpful.

Thanks.


#8

You are Welcome to try 1, 2 and 5 at you own risk one at a time to see if it helps.

https://discourse.pi-hole.net/t/i-concatenated-every-blocklist-i-could-find/5184/3

List 3 blocks many common and useful domains, I use it when I run my YaCy Search Engine.


#9

It worked perfectly! Except when I ran List 1, I liked it except it blocked a game my kids play called Roblox. Is there a way you can edit that list and make the website (www.roblox.com) to work and keep everything else the same? That’s the only disadvantage.

Thank you very much!


#10

Try unticking this list or adding your site to the whitelist /admin/list.php?l=white

https://smokingwheels.github.io/Pi-hole/yacysearchengine

I don’t use it unless I am crawling sites with a Yacy search engine, you should be able to engage the list allhosts.


#11

I don’t have any problems with Yacy list, whenever I untick “Allhosts” list, roblox works… but when I keep it checked, the website doesn’t work at all. So my issue with “allhosts” list, I like that list but only if you could find any workaround for roblox.

Thank you by the way! :slight_smile:


#12

Thanks for the reply.

May I ask did you whitelist roblox?
Depending on your total numbers on the lists, I have noticed a little delay before the site is unblocked and even had to close and open a new tab to try again. Minor issue. I just tried it and the TLS handshake has a little delay. I have set the cache on FireFox to zero 0.


#13

I’m using Google Chrome, and I already whitelisted (roblox.com & www.roblox.com) but the issue was the same. However, I just tried it now with all lists checked, it’s working. I’ll assume you fixed something or it truly takes time.

Thank u man!