"No internet" when setting Pi-Hole as DNS server

Please follow the below template, it will help us to help you!

Setup Pi-Hole on OSMC, everything seems to be working fine. I can access the admin interface. I have set listening to all interfaces, just in case (the Rasberry is connected via ethernet). I have disabled the DHCP (my router can handle it) and as soon as I set the router DNS setting to the Pi-Hole, all the connected devices lose internet access. I have checked many previous posts for the same issue with no luck.

Any help appreciated. Thanks!

Expected Behaviour:

Connected devices should have internet access.

Actual Behaviour:

Mobile phone shows “No internet”. Laptop internet requests time-out.

Debug Token:

https://tricorder.pi-hole.net/7er36kpvqr

I’ve had this very same problem after every update or reinstall of PiHole. Usually, for me at least, after setting the router’s “LAN” DNS to the PiHole I lose all connectivity till the PiHole is rebooted. That may be because I have Cloudflared installed and rebooting forces a DNS restart. Also, please make sure you’re adding PiHole to the LAN DNS settings and not the WAN DNS settings. If that doesn’t help, get a debug log token and some of the Gurus here will chime in shortly.

More specific, you only have to set the DHCP service DNS setting on the router:

If dont have those settings on the router, you can try do below:

Thanks BrownForce and deHakkelaar for your replies.

BrownForce: Tried that with no success. My router only mentions “DNS” and I start to believe that it means “WAN DNS”. And from other replies in this forum, I figure out that it is quite common for ISP routers not to provide an option to change the “LAN DNS”.

deHakkelaar: I installed Pi-Hole on OSMC which interferes with the DHCP functionality. I will give it a try on a separate Rasberry over the weekend.

For now, I have changed the DNS on the devices and seems to be working.

Thanks all again for the help!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.