No access to admin page after PiHole installation

I followed exactly these intructions this morning on a native OS install that went along very smooth - no error messages.

The services just started fine from what I could follow from the installation process, and then with any of my web browers, I'm getting this picture


and this picture


The same after rebooting the deivces :roll_eyes:

I used as OS the latest Raspbian Stretch image of November 2017.

I've tried the installation of Pi-Hole on the lite and on a full OS image, however no luck, and am digging mysefll through this forums and other posts to figure out on how to troubleshoot further :frowning:

It looks like you have JavaScript disabled, and the CSS can't load. Can you reach the web interface? http://pi.hole/admin

Thank you for the suggestion, and I can confirm that my browserx have JavaScript enabled.

I've tested this with an online tool "How to enable JavaScript in your browser", and it confirms that my browser is indeed JavaScript enabled

Based on other discussions found with "How to detect whether CSS enabled or not using Javascript", I can also conclude that my browsers support the CSS.presentation.

Concluding, my browsers setup ought to be fine, otherwise I would see the same symptoms when accessing other web portals...

OK, instead of using an Raspberry Pi device and flashing the Raspbian OS image every time, I went ahead and installed the Debian with Raspberry Pi Desktop OS on my PC, and am getting during the Bash Script installation, the following error message on the screen:

main: line 1870: /usr/bin/pihole-FTL: No such file or directory

And firing the script again, am getting the following output:

pihole-FTL: no process found
/opt/pihole/ line 56: /usr/bin/pihole-FTL: No such file or directory

Thus, not sure how robust the installation process is...

What is the output of file /usr/bin/pihole-FTL and uname -m ?

It may be that the Raspbian Desktop version is not the same architecture as your machine.

It is a i386 Intel platform.

The Raspbian Deskop is not for the ARM, however for Intel platforms based on the native Debian 9.x distribution.

Also give the output of uname -a.

I know that Raspbian Desktop is not the same as normal Raspbian.

Just to make sure I can reproduce the same observations, I reinstalled the PC again with the Raspberry Pi Desktop OS from its DVD image file.

And then launched the PiHole installation script, and the installation went just fine confirming with the semi-last line "Pi-hole blocking is Enabled" and providing the last output line:

pihole-FTL: no process found
/opt/pihole/ line 56: /usr/bin/pihole-FTL: No such file or directory

Firing the command "uname -a" provides the following output:

Linux raspberry 4.9.0-4 amd64 #1 SMP Debian 4.9.65-3deb9u1 (2017-12-23) x86_64 GNU/Linux

Firing the command "file /usr/bin/pihole-FTL" provides the following output:

/usr/bin/pihole-FTL ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, for GNU/Linux 2.6.24, BuildID[sha1]=82ab7fe1a1fe69f5f1dd0ea92d72447bff4e37cc, not stripped

And the PiHole admin console is displaying:

On the PC (not Raspi), whats outcome from below two ?

uname -m

dpkg --print-architecture

Sounds like a similar issue as this thread:

1 Like

As requested, here the output of "uname -m":


And the output of "dpkg --print-architecture":


Following the exchanges on another post, further info can be provided.

Output of "strings /usr/bin/pihole-FTL | head":


Output of "dpkg -S":

dpkg-query: no path found matching pattern **

Output of "stat":

stat: cannot stat '': No such file or directory

Output of "whereis":

Thus, from above steps, to me it looks like a library is missing...

However, when firing the command "sudo apt-get install libc6" as suggested with another post, I'm getting the following output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version (2.24-11+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I've done further queries on the Debian 9.x platform as per another post, and share the results as depicted with:

That is how to install the 32 bit "libc6" package.
If you run the 64 bit "pihole-FTL" binary (file /usr/bin/pihole-FTL) , on a 32 bit distro (dpkg --print-architecture), with a 64 bit kernel (uname -r) , on 64 bit capable hardware (uname -m), it will need the 64 bit version of that "libc6" package.
You could try to install the 64 bits version of that package with below one:

sudo apt install libc6:amd64

This will only work if the "amd64" packages are included in "/etc/apt/sources.list" file.
What do you have now in "/etc/apt/sources.list" ?

EDIT: Am curious now which distro is mixing 32 with 64 bits out of the box.
Which distro did you install ? Do you have a download link ?

EDIT2: Owh and whats outcome for below ones ?

apt-cache policy libc6

apt-cache policy libc6:amd64

Here the answers as requested, I have manually installed the libc6:amd64 package as depicted with:

The distribution is a native Debian Stretch 9.x Linux OS taylored for use with Raspberry Pi deskop. You can download its DVD Image file with this hypertext download link.

The OS packages update policy is as depicted:

Anything else I need to provide, or are we good to try the re-installation of PiHole?

Your a patient man :wink:
I would have tried already :smiley:
Check if that missing 64 bits library is installed now before go ahead and try install again:


stat /lib64/

But I wouldnt have installed this "Debian Stretch with Raspberry Pi Desktop" on an Intel/AMD machine except maybe if your a developer for Raspberry Pi things.
I would have installed the regular Debian stretch distro ... a pure 64 bits version.
And without a desktop if you dont need it.

EDIT: Ohw thanx btw for the extended info!

EDIT2: Forgot to ask, anything in this folder ?

grep -v '#\|^$' -R /etc/apt/sources.list.d/

Here the requested information as depicted with:

And I will now go eahed and try the installation from scratch based on the outlines and learnings from previous posts.

I have reinstalled Raspberry Pi deskop (Debian Stretch Linux for the Intel platform) from its DVD Image on an Intel based platform recognised as x86_64 (output of "uname -r") and i386 (output of "dpkg --print-architecture") architecture.

Have updated the OS with the usual "sudo apt-get update ; sudo apt-get -y upgrade" commands and, right after, manually installed the libc6:amd64 package with the command "sudo apt install libc6:amd64".

After all that, I fired the PiHole installation process with the known commands, and everything just worked fine - the installation process ran smooth - no errors; the UNIX processes are all running fine upon installation completion including the intially failed pihole-FTL process.

I now have access to the admin page after its installation. :slight_smile:

1 Like

Nice you found a solution for this issue as there seems to be more people trying to install Pi-hole on a mixed 32/64 bits distro that is a bit hard to detect for the Pi-hole installer.
It threw me off completely at first.
I am still curious though why one would install a 32/64 bit distro instead of a pure 64 bits one?
The only reason I can think of is if your into developing for Raspberry Pi which has a 32 bits architecture (uname -m).
Or need to run very old software that only has binaries available for 32 bits.

You can test from a client PC now with the nslookup command:

nslookup pi.hole <PIHOLE_IP_ADDRESS>

If that works, configure your router to push the Pi-hole IP address as a DNS server to its clients through DHCP:

If settings lacking on your router to push DNS through DHCP, Pi-hole has a solution for that too:

Whenever changing DHCP settings, remember to renew the DHCP leases on the clients by either disconnecting & reconnecting them from network or reboot them!
When everything configured as it should, the nslookup command, run on a client PC, should also work now if you leave out the "<PIHOLE_IP_ADDRESS>" bit eg:

nslookup pi.hole

Or a naughty domain:


Cheers :popcorn:

From what I understand, the Debian Stretch release of the Raspberry Pi Desktop for PCs ought to be a x86 distribution based on Debian 9.x and the PIXEL desktop.

The only explanation I can find is indeed having a x86 platform to connect directly to the Raspberry Pi devices and do some development with them when hooked up on your PC.

The PiHole application is now working fine under the Raspberry Pi Desktop, and am using this kind of setup as a use case for teaching purposes.

This said, thank you for your support and hints provided sofar on this post. :+1:

Thanks for the reading.
Happy hunting!