New user, Pi1 with latest Raspbian is glacially slow


#1

First post here, decided to set up pihole on original Pi1, after reflashing SD card with latest Raspbian.
Has been running for a few days, but Chromium causes everything to grind to a halt.
When first set up, managed to eventually login and show dashboard.
Got home today, and Ads not being blocked. Unresponsive, so power cycled to reboot.
Now it took many minutes to reach login prompt, and showing 100% activity.
Should performance be this poor on a Pi1?
Ads were being blocked for a few days…


#2

Please send us the token generated by

pihole -d

or do it through the Web interface:


#3

The original Pi was very limited, 256 MB of RAM the second release upgraded to 512 MB which helped a lot.

If you have the original 256 unit you are likely to see issues running PI-hole on the Pi with nothing else running. The DNS stuff all works perfectly but when you start accessing the web interface for longer queries of the database things start to fall over. Trying to run something like Chrome on top of the Pi-hole software is a sure route to issues.

I eventually gave up on my 256 MB Pi for Pi-hole use.


#4

Pinout: Pi model B V1.0 revision 0002 BCM2835 256Mb
Debug token gj28iu4s76


#5

That is a pretty lightweight device, particularly in the RAM department. Pi-Hole DNS resolution isn’t much of a load, but it takes some CPU to serve up the web admin, and then running Chromium requires the desktop to be running (more RAM and CPU).

For this Pi, it would be best to run it headless (don’t enable the desktop GUI) and not run a browser on it. You have the standard 7 block lists loaded, and this is likely using up most of the available RAM, which may result in disk memory swaps (very slow).

You can free up some RAM by shifting your blocking mode to NXDOMAIN. This will cut the memory used by storing the gravity list by 50%, since there won’t be a separate entry for the A (IPv4) and AAAA (IPv6) records.

https://docs.pi-hole.net/ftldns/blockingmode/

There is nothing abnormal shown in your debug log, so it’s certainly a device limitation you are seeing.


#6

Thanks. I thought it might be a struggle to run Pi-Hole on a Pi1.
Have now moved to a Pi2 :grin:


#7

Given that you have two Pi’s, I would use the Pi1 as a parallel Pi-Hole. Put on the lightest OS you can, load the standard blocklists, run it headless, you could even turn off the Web GUI. It will work fine for Pi-Hole only.

List the two Pi-Holes as your DNS servers. Usually, but not always, clients favor the first one listed, so make that your Pi2.

With this setup, either Pi-Hole can fail and the other carries the load.