Mit pi-hole werden Seiten oft erst beim zweiten Aufruf geladen


#1

Hallo,
ich habe pi-hole v4.0 auf einem Raspi 3b+ unter einem aktuellen Raspbian Stretch lite am laufen.
Via LAN-Anschluß an Fritzbox 7490 (diese als DHCP-Server laufend) für Telekom VDSL 100 Entertain Zugang.
ipv6 ist auf der Fritzbox (FB) ausgeschaltet.

**Ich erlebe es oft, daß DNS-Abfragen via pi-hole erst mal ins Nichts laufen, und es im Browser timeouts gibt. **
Erst beim zweiten manuellen Versuch (reload) die Seite aufzurufen wird dann die Adresse aufgelöst.
Ich erkenne hier aber kein Muster, es hängt nicht mit der angefragten Domain zusammen. Manchmal läuft es für ein paar Minuten alles Super, dann werden wieder Domains reihenweise nicht auf Anhieb gefunden.
Das war bei allen Clients zu beobachten (Win7, Win8.1, Win10, Linux, IOS12).
Das nervt sehr, alle Familienmitglieder beschwerten sich ob des instabilen Netzes, und ich nahm ihn aus der FB wieder raus.

Ich habe daraufhin pi-hole als DNS-Server testweise direkt in einem Win8.1 client eingetragen, mit Quad9 und Cloudflare als IPv4 DNS-Server in pi-hole eingetragen, also keinen Umweg über DNS-Einstellungen in der FB gemacht: Keine Besserung.

Versuchsweise habe ich einen anderen Rasperry Pi 3b (ohne plus) genutzt, aber auch hier keine Änderung.
Auch eine Neuinstallation des OS und Raspi half nicht.

Hat jemand noch eine Idee ?
Mir würde spontan noch einfallen, daß der Raspi evtl. in einen Stromsparmodus verfällt, oder ob es evtl. doch mit ipv6 zusammenhängt, obwohl ich es in der FB ausschaltete. (Soll auch so bleiben, ich bin froh, daß ich gerade mal ein paar Grundlagen von ipv4 zu verstehen glaube, ipv6 ist mir zu hoch).

Ein paar Einstellungen bei meinem pi-hole: (nach ein paar Tips aus diesem Forum)
Pi-hole Ethernet Interface: eth0
Pi-hole IPv4 address: 0.0.0.0
Pi-hole IPv6 address: 0000:0000:0000:0000:0000:0000:0000:0000
Never forward non-FQDNS angeklickt
Never forward reverse lookups for private IP ranges angeklickt
Use conditional forwarding: IP 192.168.170.1 meiner FB, sowie fritz.box

Innerhalb der Fritzbox:
DNS-Rebind-Schutz: Hier wurden folgende Domainnamen Ausnamen eingetragen: 192.168.170.43, pi-hole
(die 43 ist die IP-Adresse des pi-holes).

Wäre klasse, wenn jemand das lösen könnte.
Ein netzweiter Ad-blocker ist schon was feines, speziell für die mobilen Geräte unseres Haushaltes.
Danke!


#2

Poorly translated through Google Translate - Schlecht übersetzt durch Google Translate

Please run debug, upload the log and post the token - Bitte starte das Debug, lade das Log hoch und poste das Token.

pihole -d

or do it through the Web interface:


#3

Hello,
Thank you for jumping-in.
I created the debug log via the web interface, and hope it has been uploaded automatically.
The debug token is: 7eog18p9en

Tuetenflieger


#4

Facing similar problems with my pi 3B. More logs usefull or is the problem already known ?


#5

Please generate a debug log and upload it (again). The first one expired and we didn’t retrieve it in time. Thanks.


#6

Hello,
I repeated the debug log now.
My debug token is: h2n12jfnya

Thank you for your help.
Tütenflieger


#8

A few problems noted in your debug log. Your router is at 192.168.170.1. Your Pi-Hole should be on this address range - it looks like it was setup to listen on address 192.168.170.43. But farther down in the log you have Pi-Hole IP set as 0.0.0.0 (NULL). This is incorrect. The Pi-Hole IP of xxx…43 will work, but you need to reconfigure Pi-Hole to listen at this IP.

The correct setup would be router at xxx.1, Pi-Hole at xxx.43 with a static IP. DNS on your router set to xxx.43 only (no second DNS). Turn off DNS rebind protection on your router.

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface:
   192.168.170.43/24 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] view.atdmt.com.66842.9517.302br.net is 0.0.0.0 via localhost (127.0.0.1)
[✓] view.atdmt.com.66842.9517.302br.net is 0.0.0.0 via Pi-hole (0.0.0.0)
[✓] doubleclick.com is 216.58.207.142 via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Setup variables
    PIHOLE_INTERFACE=eth0
    IPV4_ADDRESS=0.0.0.0
    IPV6_ADDRESS=0000:0000:0000:0000:0000:0000:0000:0000

A few helpful threads:


#9

Hello Jfb,
Thank you for your help, the pi-hole is working now after changing the IP-adresses in /etc/pihole/setupVars.conf to:

IPV4_ADDRESS=192.168.170.43/24
IPV6_ADDRESS=

Actually, I was pretty sure these were my default values already, and I changed them to 0.0.0.0 on purpose, following some hints in the net for solving my problem…

I assume, one part of the problem solving was also, I originally added in my FritzBox router settings for the DNS server only one time the IP of the pi-hole, I did not enter them on both field, the second one was originally empty. Now I have in both fields (the same) pi-hole IP adress.

The only left issue is I can not setup the IP-adress of my Fritzbox router in the pi-hole as a DNS server to solve the local adresses. This is not working. This would help to differentiate and identify the local clients in my network.

Tütenflieger