Majority of traffic through one client (Eero settings)


#1

First off I am a total newbie that is just trying to learn. So I hope I can explain my concerns. I do believe PI hole is working.

Current Set up.
Modem : Arris TM 1602
Router: Eero Mesh Network
Apple Time Capsule: Being used a Switch to allow more network cables to be plugged into the Eero Gateway.

I do believe PI Hole is working. But I do have one Client. The Eero Gateway ( Eero Called the main router a Gateway) that keeps coming up a Top Client. This Access point currently has 5 devices connected to it. either connected through the Time Capsule or through WIFI.

As shown in this picture.
https://imgur.com/gallery/Qjht3Yo

Here is the Queries for it.
https://imgur.com/gallery/SMZ7ZhQ

I know it should show some info. But I guess I was under the impression that it would show each IP address as a Client. So how come its showing the Gateway instead of the devices them selfs

Here is my Debug Token:
z3bcydp17q

Any help is appreciated. Once again, I am a newbie that is interested in learning as much as I can about computer / networking.

Thanks again.


#2

There is a setting on the web admin page (Settings > DNS) for “conditional forwarding”. Enabling this allows the router to provide the names of the connected clients. Select this and see if there is improvement.


#3

I will give it a shot. Now, once again total newbie question. But My Local Domain name is the same as my SSID. I know I know, I am a total newbie and I’m sure some people are laughing. I am just making sure im doing it right and learning all the correct terms.

Thanks again,
Alan


#4

Nobody is laughing. Everybody starts somewhere.

If conditional forwarding doesn’t work, you can use the DHCP server built into Pi-Hole instead of the DHCP server in your router. With this setup, the Pi-Hole gets the client name directly from the clients during the DHCP handshake, and there is no performance difference between DHCP on Pi-Hole and DHCP on your router.


#5

So only way to tell if the conditional Forwarding worked is by waiting correct? I suppose if its working Eero-Gateway should go down on the Top Client list as more devices actually report more accurately. Correct?


#6

You can restart the FTL process and reload the page. Then check the query log and see if you are getting individual clients or only the router.

sudo service pihole-FTL restart

Another option is to “disable query logging and flush logs” (Admin GUI > settings > system), then re-enable logging. This will clear the previous data.


#7

Just did that. So we will see what happens in a few and see what pops up. So far only 3 clients have appeared. Now we play the waiting game.

Thank you for the help. Hopefully, this will resolve it.


#8

umm so it still appears that my router / Gateway is still getting a lot of queries and still a top client. Maybe thats just how this set up is suppose to work. But some things to note that I don’t. I know I have 23 connected devices on the network. PI is telling me I only have 7 clients. I believe most of the missing clients are coming up on the PI-hole UI as Eero-Gateway. Any other ideas / Pointers?


#9

I would go with the Pi-Hole DHCP server. Disable DHCP on your router, and enable it on the Pi-Hole. Then force all clients to renew their lease (how depends on the client).


#10

I don’t think I can disable DHCP on my Eeros

This is all I can do with my Eeros. Below are pics of the three settings I have ( Automatic, manually, or bridge.

Next picture shows what settings it’s askinf for for manual.


#11

Normally it’s not a good plan to have multiple DHCP servers on the LAN, but we can make it work here. We’ll set your router as DHCP server for only the IP address of the Pi-Hole, then have the Pi-Hole assign the DHCP to the rest of your network.

What is the static IP address of your Pi-Hole?


#12

192.168.7.60


#13

I figured out my Problem. Inside Eero App that controls the configuration of the Eero system I had a setting called Local DNS Caching Activated. By turning that off and clearing my logs. I now see all clients individually instead of the gateway showing all the traffic.

Thanks to those that helped. I hope this can help anyone else down the road.


#14

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.