Lokale Namensauflösung nur bei IPv4 Adressen

#1

Hallo, ich habe das “Conditional Forwarding” aktiviert und meine Fritz-Box dort per IP-Adresse und der Domain fritz.box angegeben. Seitdem sehe ich die DNS Namen zum Beispiel der “Top Clients”. Leider scheint dieses aber nur für IPv4-Adressen zu funktionieren. Diese werden richtig aufgelöst, die IPv6-Adressen allerdings nicht.

Warum werden die IPv6-Adressen der lokalen Devices nicht aufgelöst?

Gruß

Torsten

0 Likes

#2

Hallo Torsten,

ist die Fritzbox denn in der Lage die IPv6 Adressen aufzulösen?

versuch bitte einmal

dig -x 192.168.1.2 @192.168.1.1

und

dig -x fda2:.... @192.168.1.1

wobei Du

  • 192.168.1.1 durch die IP Deiner Fritzbox ersetzt,
  • 192.168.1.2 durch die IP eines Deiner Endgeräte ersetzt und
  • fda2:... durch die IPv6 eines Deiner Endgeräte ersetzt (einer, der auch in der Top Clients Tabelle gezeigt wird).

Was ist jeweils die Ausgabe?

0 Likes

#3

Hallo,

folgende Ausgabe habe ich bei IPv4:

; <<>> DiG 9.10.3-P4-Raspbian <<>> -x 192.168.111.63 @192.168.111.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30437
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; QUESTION SECTION:
;63.111.168.192.in-addr.arpa. IN PTR

;; ANSWER SECTION:
63.111.168.192.in-addr.arpa. 9 IN PTR NEO.fritz.box.

;; AUTHORITY SECTION:
63.111.168.192.in-addr.arpa. 9 IN NS fritz.box.

;; ADDITIONAL SECTION:
fritz.box. 9 IN A 192.168.111.1
fritz.box. 9 IN AAAA fd00::cece:1eff:fea3:8987
fritz.box. 9 IN AAAA 2a02:810d:580:2190:cece:1eff:fea3:8987

;; Query time: 0 msec
;; SERVER: 192.168.111.1#53(192.168.111.1)
;; WHEN: Fri Aug 10 18:33:13 UTC 2018
;; MSG SIZE rcvd: 158

Die Answer-Section ist richtig. NEO ist der Name des Devices.

Diese Ausgabe habe ich bei IPv6:

pi@raspberrypi:~ $ dig -x 2a02:810d:580:2190:34f9:af9d:a89f:6e16 @192.168.111.1
; <<>> DiG 9.10.3-P4-Raspbian <<>> -x 2a02:810d:580:2190:34f9:af9d:a89f:6e16 @192.168.111.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 6143
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;6.1.e.6.f.9.8.a.d.9.f.a.9.f.4.3.0.9.1.2.0.8.5.0.d.0.1.8.2.0.a.2.ip6.arpa. IN PTR

;; AUTHORITY SECTION:
0.9.1.2.0.8.5.0.d.0.1.8.2.0.a.2.ip6.arpa. 9 IN SOA fritz.box. admin.fritz.box. 1533926201 21600 1800 43200 10

;; Query time: 0 msec
;; SERVER: 192.168.111.1#53(192.168.111.1)
;; WHEN: Fri Aug 10 18:36:41 UTC 2018
;; MSG SIZE rcvd: 150

Hier fehlt die Answer-Section. Bedeutet das, das die Fritz.Box keine IPv6 Adressen auflöst?

Ist das ein generelles Problem der Fritz.Box oder ist hier in der Fritz.Box etwas falsch konfiguriert?

Danke und Gruß

Torsten

0 Likes

#4

Ja, die Fritzbox weiß scheinbar keinen Hostnamen zu dieser Adresse.

Da bin ich überfragt. Ich verwende selbst keine Fritzbox und plane das auch nicht in absehbarer Zeit zu ändern.

0 Likes

#5

Trotzdem Danke für Deine Info, ich werde parallel AVM befragen. Schönen Abend noch!

0 Likes

#6

Hallo Torsten.
Ich habe das gleiche Problem.
Hast du hierzu von AVM eine Antwort erhalten?
Gruss
Klaus

0 Likes

#7

Hallo Klaus, sorry für die späte Antwort, ich habe von AVM nur aus der Wissensdatenbank eine Anleitung für die Konfiguration von IP v6 bekommen. Diese habe ich so eingestellt und seitdem funktioniert die Namensauflösung bei mir.
Gruss
Torsten

0 Likes

#8

Ich habe das gleiche Problem, bekomme es aber nicht gelöst.

Infos:
FritzBox 7580
PiHole aktuellste Stable mit Stubby als lokaler Resolver

PiHoleUI


In der FritzBox habe ich unter Internet -> Zugangsdaten -> DNS-Server 2x die IPv4 und 2x die IPv6 von PiHole eingegeben

Unter Internet -> Zugangsdaten -> IPv6 folgendes:

Unter Heimnetz -> Netzwerk -> Netzwerkeinstellungen -> IPv4 Adressen habe den die IPv4 von PiHole eingetragen.

Unter IPv6 Adressen habe ich folgende Einstellungen:

Auch habe ich folgende Einträge im DNS-Rebind-Schutz eingetragen:
192.168.178.10
fd00::daec:f65c:4575:e8a7
pi.hole

Wo liegt der Fehler?

0 Likes

#9

Keiner eine Idee?

0 Likes

#10

Auf welche IPv6 Adresse hört Dein PiHole? Hast Du die fix vergeben? Falls nicht, führt das zwangsläufig zu Fehlern.
Du kannst das unter Settings > System überprüfen.

Unter Upstream DNS Server hast Du jeweils Localhost auf Port 53, also PiHole angegeben. Hier müsste doch die Portnummer von Stubby angegeben werden.

0 Likes

#11

PiHole bekommt eine fixe IPv6 Adresse via ULA der FritzBox. Ist also eine fd00:: Adresse

Unter Upstream ist Stubby hinterlegt: 127.0.1.1
Localhost wäre 127.0.0.1

0 Likes

#12

Das ist nicht ganz korrekt.
Dein PiHole kriegt lediglich den Präfix vom Router mitgeteilt. Die letzten 64bit der Adresse baut sich Dein Client selbst.
Ob bei ULAs auch Privacy Extensions greifen, weiss ich nicht genau.
Deshalb meine Frage: Hast Du dem Gerät eine fixe IPv6 Adresse zugewiesen und hört PiHole auch auf die?

Ich bezog mich auf IPv6, da Dein PiHole ja unter IPv6 nicht funktioniert.
Während bei IPv4 mit 127.0.0.0/8 zig Adressen zur Verfügung stehen, steht bei IPv6 lediglich ::1/128, also eine einzige Adresse zur Verfügung.

0 Likes

#13

Also PiHole nutzt dauerhaft die gleiche IPv6 die ich auch in der FritzBox in DNSv6 hinterlegt habe.
Es blockt auch erfolgreich IPv6 DNS.

Was genau brauchst du für Infos?

0 Likes

#14

was funktioniert denn nicht?

0 Likes

#15

Wie ich bereits schrieb:
Es werden bei IPv6 keine Gerätenamen angezeigt, obwohl “Conditional Forwarding” aktiv ist.
Bei IPv4 geht es

0 Likes

#16

Hier noch ein Screnshot:
pihole

0 Likes

#17

Das einzige was ich sehe was nicht korrekt konfiguriert ist, ist der IPv6 Upstream 0::1#53
Hier antwortet Dein PiHole und nicht Stubby. Zumindest in der Standardkonfiguration.

Mit anderen Worten, wenn PiHole die Adresse nicht auflösen kann, fragt er sich selbst, statt ein DNS Resolver.

0 Likes

#18

Hmm macht Sinn.
Was müsste ich denn da eintragen?

0 Likes

#19

Du musst Stubby so konfigurieren, dass er nicht auf Port 53 horcht. Dieser Port ist vom PiHole schon belegt. Nimm bsp Port 54.
Übrigens, Du kannst die Null vor den Doppelpunkten weglassen. ::1#Portnummer reicht aus.
Würde dann so aussehen ::1#54

0 Likes

#20

Scheint nicht zu klappen.
In stubby bei " LISTEN ADDRESS" habe ich jetzt folgendes eingetragen:
0::1@54

und in PiHole einmal mit “::1#54” versucht und einmal mit “0::1#54”
Beides leider ohne Erfolg

0 Likes