Log in failed why me:(

inlog fail
I installed pihole and go to the admin website to controll my pihole I tried logging in on the admin website but the password was always wrong I reset the password several times but without result
i searched on google already but no results
and i tried every website but when i search it says this: has refused the connection

SSH in to the Pi-hole server and run:

pihole -a -p 1234

That will set the password to 1234.

Go to the web interface and use that password. If it works then we know it works and you're probably using a password that is not compatible.

That did i already and i tried to remove the password

But i can try

Ok another problem cannot be reached.

By default there is no TLS/SSL setup for the pihole, meaning that using https:// will not work.
Most browsers will try to default to https and I suspect the same is happening here.
Keep trying , removing the s from the http when the browser adds it back in.
For me on Firefox, sometimes it can take 5+ times before the browser accepts I do not want to use HTTPS.

1 attempt
its http right?
But the same error

If you've followed the standard installation that Pihole provides, then yes it will be HTTP.

Are you sure the Pihole is up? if you ping it ping, do you get hits?

Also, what is the exact error the browser is saying? Can you show us? cannot be reached.

or raspberry pi refuses connection

Yeah but whats the login page i forgot it

If your current devices are configured to use the Pihole as their DNS server, you can access it from http://pi.hole/admin/index.php?login
Using this method you wont need to know the IP address of the Pi.

On that matter, can you explain what you installed the Pihole on?

You said this so I'm assuming you have a separate RasPi set up as a Pi-hole - have you set your router to use the Pihole as the DNS server?

No how do i do that?

Okay another problem i used something like piholestomp
But hires my error This site cannot be reached The DNS address of pi.hole cannot be found

I'm assuming that quote is in reference to:

If that is the case, then make sure you have followed the post installation instructions (and maybe go back and confirm you have followed all the steps prior to that). The very first link in that page shows you the general steps on how to set the Pihole as the DNS server for your DHCP hosts.
I should note that it is not a step-by-step guide for every make router out there, so I would heavily advise that if you're not comfortable with making changes and don't know how to make backups, that you should either get some help or hold off until you've done your research and are knowledgeable with the steps ahead.

It seems to me that you haven't set the Pihole as the DNS server inside the router - because of that no clients are being assigned this information via DHCP.

I have searched for 'piholestomp' and 'pihole stomp' but found no results, so I have no idea what you are referring to there.

This error would have occurred when you tried http://pi.hole/admin/index.php?login, proving that whatever device you are using does not have the Pihole set as it's DNS server.
If you try this should give you a different error - could you provide us with that too?

You guessed it right This page is not reachable192.168.2.11 took too long to respond

i tried it again i forgot to start my raspberry

finally i made it thank you! :slight_smile: