IPV6 pihole block page gives error, IPV4 works ok. Admin page works on IPV6 and IPV4

IPV6 block page:
[ERROR]: Unable to parse results from queryads.php: Unhandled error message ()

IPV6 admin page:
Works perfect.

IPV4 works ok.

Please send us the token generated by

pihole -d

or do it through the Web interface:

Your debug token is: roqyf3zcim

2018-03-25 11:35:42: (mod_fastcgi.c.2543) FastCGI-stderr: PHP Warning:  file( failed to open stream: Connection refused in /var/www/html/pihole/index.php on line 136

Hmm @Mcat12, @DL6ER, or @PromoFaux might have more insight into this message.

To rule out any errors from me I just installed a fresh pi with latest rasp strech.
Without doing anything exept setting fixed ipv4 and ipv6 adresses, I installed pihole with the curl.

IPV4 block page and admin page: OK
IPV6 block page: error: [ERROR} unable to parse rsults from queryads.php; unhandled error message: (invalid domain!)
IPV6 admin page: OK

Rebooted just in case.
Debug: j10yfze8ku


   Mar 26 10:59:13 dnsmasq[15591]: failed to load names from /etc/pihole/local.list: No such file or directory
   Mar 26 10:59:13 dnsmasq[15591]: failed to load names from /etc/pihole/black.list: No such file or directory
   Mar 26 10:59:13 dnsmasq[15591]: failed to load names from /etc/pihole/gravity.list: No such file or directory

but I see there are entries in your gravity.list...

paging @DL6ER for his input.

I can add some sites in black and whitelist to see if that is needed for the files to be created once?

added whitelist.test and blacklist.test in the lists.
rebooted, flushed the dnsmasq log and tested the [ipv6]: same error.

This means that the resolver wasn't able to open the files for reading. Check if they are present and readable by user/group pihole.

1 Like

Can you

sudo chown pihole:pihole /etc/pihole/gravity.list

and try again?


Not to be a wise guy, but this is a standard rasp install.
Are you not able to replicate this in house?
Probably faster then me uploading the logs:)


Indeed, I tried with a brand new Raspberry Pi yesterday morning and have not been able to reproduce your issue.

Really ? mmm now I am totaly confused and defeated.
Can you let me know how you did your eth0 setup?
Perhaps this has something to do with my choice of IPV6 address range.
What ipv6 are you using as a fixed address on eth0?

And what happens if you do http://[your ip6] ?

This is my dhcpcd.conf:
interface eth0
static ip_address=
static ip6_address=fd00:42f8:caae:d92e::02/64
static routers=
static domain_name_servers= fd00:42f8:caae:d92e::04
static domain_search=fritz.box

static domain_name_servers= fd00:42f8:caae:d92e::04
Yes: this is a diffrent box. It is not the raspberry. I know.


It looks like this line might be part of the issue:

Make a new debug token.


Yes: -
-That is not IPV6

-I am not a programmer and there is probably a reason for callng all this PHP, but the request of the client is towards the block page, not the admin page, so why is there even so much logic in that request? Would it not be much faster just to display a simple jpeg?

-Still unable to to understand why this happens to my setup amd not in your lab.

Thanks for all the efforts

The block page does more than just show that the site was blocked. I also looks up what lists caused the domain to be blocked. That code is in another file, which it calls with that command.

Depending on what type of request was made, the block page either returns an empty page with a single pixel, returns a bigger 404-like page, or returns the full block page. It determines this automatically.

Have you added any special iptables rules? Also, why do you want to view the block page over your raw IPv6 address instead of a hostname?

Thanks for that clear answer. I did not know that and it clearly explains my question regarding the PHP.
There is no extra rules or setup other than just a blank pi rasp strech install with fixed ipv6 addresses. No iptable rules or whatever.

I wanted to test raw ipv6 as I (incorrectly?) assumed the ipv6 block page is recieved the same way as the direct ipv4 test.
Also need to be honest in regards to ipv6 I am not up to date with knowledge.
So if I wanted to test the ipv6 block page. What to enter in a addressfiled in the browser.?
[raspberrypi] ?


You should just need to enter in the IPv6 address like that (or add on a random path).

If you're still having the issue, make a new debug token.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.