IPv6 & Armbian


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Get IPv6 on my OS and on Pi-hole too for block all thats ads :slight_smile:

Actual Behaviour:

No getting IPv6 on Armbian. Its configured (Works perfectly in my network other devices…) but on http://ipv6-test.com/, getting nothing in the IPv6 section.

Debug Token:

k517ykbx9y


#2

I only see one link local address, which we don’t use. Can you let me know the output of these commands:

dnsmasq -v
ip -6 a
test -f /proc/net/if_inet6 && echo "IPv6 supported" || echo "IPv6 not supported"

#3

Yes sure !

root@orangepiplus:/home/diez# dnsmasq -v
Version de Dnsmasq 2.75 Copyright © 2000-2015 Simon Kelley
Compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify

Ce logiciel est fourni sans AUCUNE GARANTIE.
Dnsmasq est un logiciel libre, il vous est permis de le redistribuer
sous les termes de la licence GPL (GNU General Public License), version 2 ou 3.
root@orangepiplus:/home/diez# ip -6 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
inet6 fe80::e0a6:3bff:fecd:2fa/64 scope link
valid_lft forever preferred_lft forever
root@orangepiplus:/home/diez# test -f /proc/net/if_inet6 && echo “IPv6 supported” || echo “IPv6 not supported”
IPv6 supported

Thanks you!


#4

Try https://test-ipv6.com other site is very buggy sometimes


#5

Does your router support IPv6? Your OS does, but you don’t seem to be getting anything from your router.


#6

Hey there is results from my W10 PC and from the OrangePi
Do you want see my settings in IPv6 settings of my router ?

Edit for security, one pic deleted :confused:

Thanks You!


#7

Yes, that will be helpful


#8

There you go, sorry i don’t find any settings of language in router interface :confused:

One Pics deleted for security reason


#9

Huh, tricky problem :slightly_frowning_face:


#10

Have you tried using Pi-hole’s built in DHCP server instead? It’s a nice solution when routers give difficulty.


#11

If I do that it block the video stream of the TV on the decoder. It’s a restriction… And sincerely I think it wouldn’t solved the problem :slight_smile:
Thanks you!


#12

Some change here :

Test with IPv4 DNS record
ok (0.354s) using ipv4
Test with IPv6 DNS record
bad (0.137s)
Test with Dual Stack DNS record
ok (0.390s) using ipv4
Test for Dual Stack DNS and large packet
ok (0.330s) using ipv4
Test IPv4 without DNS
skipped (0.403s)
Test IPv6 without DNS
skipped (0.201s)
Test IPv6 large packet
bad (0.278s)
Test if your ISP’s DNS server uses IPv6
ok (0.419s) using ipv4
Find IPv4 Service Provider
ok (0.462s) using ipv4 ASN 12322
Find IPv6 Service Provider
bad (0.099s)


#13

$ sudo ifconfig eth0 inet6 add 2a01:XXX:XXXX:XXXX::2/64

Edit for security

I have write this line and 10/10 on test-ipv6.com problem solved!


#14

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.