Internet is slow using Pi-hole

I was going to post my own thread, but I feel like this is the exact same thing I am experiencing as well. The pihole had been working perfectly fine with no issues for quite some time, but about 3-4 weeks ago I started seeing this same behavior and haven't been able to figure out what exactly is going on. I probably need to document things a little better, but I feel like it may be better after rebooting the pihole for a short period of time. If I remove the pihole I don't notice any slowness issues.

https://tricorder.pi-hole.net/0zu319m9s4

I have a google wifi mesh setup. The pihole is configured for DHCP and DNS, and I also have pivpn setup on the rapsberry pi with the pihole. Not really sure what else to do at this point but take the pihole offline because it makes the internet so frustrating to use when it takes > 10 seconds to load a webpage.

I think you have a different issue, so I moved your post.


From your debug log: there are two DHCP servers on your network, one is your PI-hole , one is your router. Both advertise themselves as DNS servers. Additionally, your Pi is not able to send DNS packets to a public upstream DNS server.

✓] IPv4 address(es) bound to the eth0 interface:
   192.168.86.2/24 matches the IP found in /etc/pihole/setupVars.conf

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] serwis-laptopow24.pl is 0.0.0.0 via localhost (127.0.0.1)
[✓] serwis-laptopow24.pl is 0.0.0.0 via Pi-hole (192.168.86.2)
[✗] Failed to resolve doubleclick.com via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   
   WARN: Could not sendto() in send_dhcp_discover() (/root/project/src/dhcp-discover.c:223): Network is unreachable
   * Received 300 bytes from eth0:192.168.86.1
     Offered IP address: 192.168.86.2
     Server IP address: 192.168.86.1
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.86.1
      lease-time: 86400 ( 1d )
      renewal-time: 43200 ( 12h )
      rebinding-time: 75600 ( 21h )
      netmask: 255.255.255.0
      broadcast: 192.168.86.255
      router: 192.168.86.1
      domain-name: "lan"
      dns-server: 192.168.86.1
      --- end of options ---
    
   * Received 300 bytes from eth0:192.168.86.2
     Offered IP address: 192.168.86.6
     Server IP address: 192.168.86.2
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.86.2
      lease-time: 86400 ( 1d )
      renewal-time: 43200 ( 12h )
      rebinding-time: 75600 ( 21h )
      netmask: 255.255.255.0
      broadcast: 192.168.86.255
      dns-server: 192.168.86.2
      domain-name: "lan"
      router: 192.168.86.1
      --- end of options ---

DHCP_ACTIVE=true
    DHCP_START=192.168.86.3
    DHCP_END=192.168.86.251
    DHCP_ROUTER=192.168.86.1

Thanks for replying.

Yes, due to the inability to fully disable DHCP on a google wifi routers, I limited the DHCP of the google wifi to the .2 address which is statically assigned to the pihole. This had not seemed to be an issue, as everything seemed to have been working fine for quite some time before I began experiencing the slow page loading issue.

What do you mean by "pi is not able to send DNS packeets to a public upstream DNS server"? If that was the case, I wouldn't be able to resolve domains at all correct?

Ok, good point.


Did you change anything in between?


As part of the debug script, Pi-hole tries to resolve a known adblocking domain via 8.8.8.8 which was not successful in your case

Do you have any firewall configured?


Please run from one of your clients which experience the slowness

nslookup pi.hole

nslookup google.com

I didn't make any specific changes, I'm not sure exactly when I started seeing the issue, but I think there was an update to the pihole software somewhere around the time I feel I started seeing the problem.

I do not currently have a firewall configured on the raspberry pi hosting the pihole installation.

Server:		127.0.0.53
Address:	127.0.0.53#53

Non-authoritative answer:
Name:	pi.hole
Address: 192.168.86.2

Server:		127.0.0.53
Address:	127.0.0.53#53

Non-authoritative answer:
Name:	google.com
Address: 172.217.12.110
Name:	google.com
Address: 2607:f8b0:4002:811::200e

The pi.hole lookup showed up instantly. The google.com lookup took about 5 seconds to show up.

Did you run the commands from a client or the Pi device itself? Because it forwarded the request to Server: 127.0.0.53 which is the localhost. Instead, it should have used 192.168.86.2 as DNS server. Do you run any software on this client that might interfere with DNS? AVAST Real Site?

Do you experience the slowness on all of your clients?

A post was split to a new topic: Slow internet using Pi-hole