Slow internet using Pi-hole

I' m also having this.
I have a fresh install of pi-hole, Ubuntu 20.04.2 LTS virtual server with 6GB RAM and 8 CPU cores 100G SSD.

All devices on the network are running really slow.

Local nslookup is instant.
google.. never makes it.. times out.

░▒▓    ~  nslookup pi.hole  :heavy_check_mark: ▓▒░

Name: pi.hole

░▒▓    ~  nslookup  :heavy_check_mark: ▓▒░

DNS is running on my Mikrotik Router not jute Pi-Hole

What do you mean by that? You running an additional DNS server?

How do you announce/configure DNS server on your clients? You DHCP offer does not contain a DNS server

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   * Received 300 bytes from eth0:
     Offered IP address:
     Server IP address:
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      lease-time: 86400 ( 1d )
      --- end of options ---
   DHCP packets received on interface eth0: 1
   DHCP packets received on interface lo: 0

Side note: Blocking is disabled on purpose?


Sorry - I meant DHCP!

On the Mikrotik /ip/dns I have the pi hole as the only DNS server

Not sure how/when I enabled this, and I'll revert it

I'm not familiar with RouterOS, but with a quick search I found

I would set dns-server in the Sub-menu: /ip dhcp-server network to the IP of the Pi-hole.

Dis/Reconnect your clients from the network to pick-up the new DHCP information.

Thanks - I've updated that.

How/where do I disable this?

Bildschirmfoto zu 2021-04-12 10-21-50

Oh- that was just me testing to see if it sped things up.
I'm renewing all leases, will test and report back


OK. If you encounter issues, please generate a new debug token.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.