Installing 6. over 5. not working

First: Thank you for this cool tool!!!

I tried this last night and it worked. In Proxmox I cloned my running Pi 5 and did all three upgrade steps as per your documentation. Worked fine, but I missed the part about the 8080!!! :frowning: So I deleted everything.
Tried again today and it does not work. Something changed overnight. Please see screenshot....

Real-time signal 3 in bash could point to a memory shortage. Could you try again?

Looking at the Pi-hole core code, I don't see anything that has been merged over night (the last commit has been 3 days ago).

I upped the RAM form 4 to 8 GB, no difference. I did the exact same thing (I am pretty sure!!!) yesterday and it worked. Also increased HD from 8-10 GB, same error message.

I installed a brand new version of Pi5 and then "pihole checkout core development-v6" without a hitch. Frontend still shows. After "pihole checkout web development-v6" I try to load P6 with :8080 and I get a "Directory listing denied".

Access the web interface with

Thank you yubiuser, that fixed it. Not mentioned in the docs, or not so that I could understand it.

TELEPORTER does not import Pi5 teleport. That would be pretty bad it that does not work....

Just tried again, still can't upgrade 5. to 6. Since TELEPORT 5 does not work with 6, that would be a real bummer... I don't want to add all those lists by hand again...

Okay, I thought your issue was already solved. Just to make this crystal clear: You have installed a brand-new v5 and were able to upgrade it to v6 just fine. But you also tried upgrading an existing (different!) v5 installation and there you consistently saw the

/etc/.pihole/automated install/ line 1416: 994 Real-time signal 3

preventing the upgrade from succeeding. Is this correct?


I am running this on Proxmox and cloned the working Pi5 container. The upgrade consistency fails as per the screen shot. Fresh Pi6 install worked without a problem!!!

If I can be of any help, just ask. I am retired, so time is not a problem!!! :wink:

Thanks for the offer, I have been thinking this through but it is actually kinda tough. Even more because we don't get the exact line where this happens, we just know

is failing somehow. The last change to the was back in October, so there is also no recent change. You see I'm noting down my thoughts in almost chaotic order here, partially hoping that someone will read through them and say: Dang! I have an idea.

Well, let's just continue thinking here. What we could try is to run pihole -g in the container right after you have seen the error message above. It will be interesting to see if this fails as well, and if, how, or if this works just fine.

I'm also working on v5.0 Teleporter support in v6.0, but this is ongoing work and unlikely to fully work as of yet:

Nope, not working....

Hope this helps!!!

This is indeed helpful - even it not very much - it is a good start!

So the error most likely happens here:

indicating we have a problem with


What is the output when you run

pihole-FTL --config files


The code is like Chinese for me.... :wink: But with your guidance I can just run the code you need...

Great! I mean ... "Segmentation fault" is surely not great but we found the root cause. Could you follow the steps under " Prerequirements (only required once)" at gdb - Pi-hole documentation ?

Once done, please run

gdb pihole-FTL --ex "r --config files"

and when it then crashes please enter


and provide another screenshot. This may already be what we need fix the bug.

Not sure I did it right, this is what I get. Don't understand the "screen" command... :frowning:

Sorry, but I really do not know what I am doing....

Type: where

This looks better, I guess....