Install fails with "[✗] DNS resolution is currently unavailable"


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pihole installs, starts, and DNS resolution works both from the command line, and from remote queries

Actual Behaviour:

Install gets this far and then borks:

[i] Restarting services…
[✓] Enabling pihole-FTL service to start on reboot…
[✓] Starting pihole-FTL service…
[✓] Deleting existing list cache
[i] Pi-hole blocking is enabled
[✗] DNS resolution is currently unavailable
[✗] DNS resolution is not available

Can confirm from using "hosts <domain_name> on the command line that there is, indeed, no DNS resolution available locally. Queries from other machines using "dig @<ip_address> also fail with server unreachable.

This is on a new Raspberry Pi, running a fully up2date OS. More confoundingly, I have an identical installation done from the same raspbian image on another identical Pi, and it installed just fine, and is running happily.

I’ve also done a complete reinstall of PiHole, and a complete OS re-image and attempted re-install of PiHole. Fails at exactly the same place every time. I’ve tried manually adding a working DNS server to /etc/resolve.conf in-between the first and second attempt by the installer to get DNS resolution, to no avail.

I’ve also googled around a bit and tried the various solutions that seem to have worked to varying degrees for other people, and still no luck.

Debug Token:

d1eo3w4po2


#2

Your gravity list is empty, and should not be.

Run pihole -r and select repair. This will both fix any problems with your Pi-Hole installation and fully rebuild the gravity list.

If the Pi is unable to connect to the internet to do this, add the following steps and run pihole -r again.

sudo nano /etc/resolv.conf

edit nameserver 127.0.0.1 to nameserver 9.9.9.9 or your preferred third party DNS service, save and exit


#3

I’ve done that, and it still comes up with exactly the same error. Somewhere along the way, resolve.conf gets overwritten again and reverts to nameserver 127.0.0.1

I’ve tried repair, and reconfigure after pihole -r, still the same error.


#4

That is normal after a repair. The repair process sets the nameserver for Pi-Hole use.

Please upload another debug log and post the new token.

There is an open issue on GitHub that may be related to your problem - install failures on a late build of Stretch.


#5

New debug log token is g4pqkdwb9p


#6

Just let me know if I need to generate another one…