Ich bekomme Unbound einfach nicht zum laufen

#1

Hallo,

seit einigen Tagen versuche ich Unbound zum laufen zu bekommen - vergeblich.
Ich gehe nach dieser Anleitung vor (https://docs.pi-hole.net/guides/unbound/) und wenn ich testen möchte ob Unbound funktioniert, erhalte ich immer folgende Meldung:

“; <<>> DiG 9.10.3-P4-Raspbian <<>> pi-hole.net @192.168.10 -p 5353
;; global options: +cmd
;; connection timed out; no servers could be reached”

Was mache ich verkehrt? Pi-Hole läuft ohne Probleme unter DietPi.

Ich habe eine Connect Box und Dual Stack bei Unitymedia.

Die IP vom Raspberry lautet 192.168.0.10

Wenn ich nach der Installation von Unbound die IP vom Raspberry unter dem Reiter DNS +#5353 bei Pi-Hole eingebe und auf Speichern klicke, kann ich keine Internetseiten etc. mehr aufrufen. Ist ja auch klar, da Unbound nicht korrekt läuft.

Könnt ihr mir helfen um dieses Problem in den Griff zu bekommen?

Gruß

0 Likes

#2

invalid IP address, only 3 bytes …

0 Likes

#3

Da habe ich gestern Abend beim erneuten konfigurieren einen Fehler gemacht. Aber davor die Tage hatte ich alles korrekt eingestellt und es funktioniert dennoch nicht.

0 Likes

#4

Probiere mal mit unbound -d -vvvv zu sehen was nicht gut geht mit unbound.

0 Likes

#5

Hallo msatter,

folgendes wird mir dann angezeigt:

root@DietPi:~# unbound -d -vvvv
[1555319531] unbound[2708:0] notice: Start of unbound 1.6.0.
[1555319531] unbound[2708:0] error: Could not open /etc/unbound/unbound.conf: No such file or directory
[1555319531] unbound[2708:0] warning: Continuing with default config settings[1555319531] unbound[2708:0] debug: increased limit(open files) from 1024 to 4152
[1555319531] unbound[2708:0] debug: creating udp6 socket ::1 53
[1555319531] unbound[2708:0] error: can’t bind socket: Cannot assign requested address for ::1 port 53 (len 28)
[1555319531] unbound[2708:0] fatal error: could not open ports

Gruß

0 Likes

#6

Sieht so aus, als wenn bereits etwas auf Port 53 läuft.

Im Tutorial wird die Datei /etc/unbound/unbound.conf.d/pi-hole.conf beschrieben, in der u.a. Unbound für den Port 5353 konfiguriert wird (“port: 5353”). Da bei dir solch eine Konfigurationsdatei nicht gefunden wird, wird Unbound auf dem Standardport 53 gestartet - was eben nicht funktioniert, weil dieser Port bereits von einem anderen Prozess geöffnet und verwendet wird.

0 Likes

#7

Was muss ich denn dann nun machen?

Auf dem Pi läuft übrigens noch no-ip, openvpn und fail2ban falls diese Info hilfreich ist.

0 Likes

#8

Die config ubernehmen die auf seite steh die verlinkst habt in deine erste post.

Est steht unter Configure Unbound

Sehe auch die post von Mibere.

0 Likes

#9

Wie wir deinem Logeintrag

Could not open /etc/unbound/unbound.conf: No such file or directory

entnehmen können, versucht Unbound eine andere Konfigurationsdatei zu verwenden.

Ändert sich etwas, wenn du einfach mal sudo systemctl restart unbound ausführst?

/EDIT: nur eine Vermutung…kann es evtl. sein, dass Unbound 1.6.0 (ziemlich alte Version) die Konfigdatei an anderer Stelle erwartet? Das Tutorial wurde sicherlich für ein Unbound 1.8.x geschrieben.
=> sudo mv /etc/unbound/unbound.conf.d/pi-hole.conf /etc/unbound/unbound.conf

0 Likes

#10

Das wird nichts anderen.

0 Likes

#11

Habe es umgesetzt und beim Befehl Unbound Status kommt nun folgendes:

sudo service unbound status

Und hier folgendes:

Wenn ich nun in den Einstellungen von Pi-Hole als DNS 127.0.0.1#5353 eingebe, wird dennoch keine Seite aufgerufen bzw. das Internet gar nicht mehr.

0 Likes

#12

Mit unbound -d -vvvv startest du unbound und kann die beenden mit CTL-c

Dann kann systemd benutzt werden oder du startest die RaspberryPI auf neuem.

Unbound testen geht mit:

dig -p 5353 pi-hole.net

0 Likes

#13

Super, funktioniert nun!

Wie kann ich Unbound bei einem Neustart von Dietpi denn automatisch starten lassen?

0 Likes

#14

Unbound sollte eigentlich automatisch starten, wenn Du das Gerät neu startest.

0 Likes

#15

Hast recht. Dauert nur einen kleinen Moment.

Ist es normal, dass nach einem Neustart die gespeicherten DNS bei Unbound gelöscht werden und jedes Mal nach einem Neustart die DNS erneut abgerufen werden müssen über einem externen DNS-Server?

0 Likes

#16

Ja, weil beim Neustart die Einträge im Cache verloren gegangen sind.

0 Likes

#17

Okay.

Nun habe ich ein anderes Problem.

Wenn ich in der config unter “private Adresse” überall und unter jeder Adresse ein # Rautenzeichen setze, dann funktioniert es.
Wenn ich nun aber unter 192.168.0.0 das # wegnehme, dann funktioniert Unbound nicht mehr.
Pi-Hole verteilt die IP-Adressen als DHCP-Server in einem Bereich von 192.168.0.2 - 8.

Wofür ist dann der private adress Bereich in der unbound.conf?
Und warum tritt dieser Fehler auf?

0 Likes

#18

The tutorial works with unbound 1.6 - no problems.

0 Likes

#19
private-address: <IP address or subnet>
          Give IPv4 of IPv6 addresses  or  classless  subnets.  These  are
          addresses  on  your  private  network, and are not allowed to be
          returned for public internet  names.   Any  occurrence  of  such
          addresses are removed from DNS answers. Additionally, the DNSSEC
          validator may mark the  answers  bogus.  This  protects  against
          so-called  DNS  Rebinding, where a user browser is turned into a
          network proxy, allowing remote access  through  the  browser  to
          other  parts of your private network.  Some names can be allowed
          to contain your private addresses, by default all the local-data
          that  you  configured  is  allowed to, and you can specify addi-
          tional names using private-domain.   No  private  addresses  are
          enabled  by default.  We consider to enable this for the RFC1918
          private IP address space by  default  in  later  releases.  That
          would  enable  private  addresses  for  10.0.0.0/8 172.16.0.0/12
          192.168.0.0/16 169.254.0.0/16 fd00::/8 and fe80::/10, since  the
          RFC  standards  say these addresses should not be visible on the
          public internet.  Turning on 127.0.0.0/8 would hinder many spam-
          blocklists   as  they  use  that.   Adding  ::ffff:0:0/96  stops
          IPv4-mapped IPv6 addresses from bypassing the filter.

   private-domain: <domain name>
          Allow this domain, and all its  subdomains  to  contain  private
          addresses.   Give  multiple times to allow multiple domain names
          to contain private addresses. Default is none

Do use IP adresses on local devices.

0 Likes