I see 17 queries and 0 blocked. Do I have Pi-hole configured correctly?


#1

Expected Behaviour:

I should be seeing many queries blocked and at least 5 clients,

Actual Behaviour:

I see 17 queries, 0 blocked, and 1 client.

Setup

I have Pi-hole installed on a Pi 2 and it’s on 10.0.0.2. I can SSH into it and everything so connectivity is no issue. I have set my router to use DNS (I can upload screenshots if needed) with 10.0.0.2 as the primary, AdGuard’s DNS server as the secondary, and Google’s as the tertiary. I don’t see many ads so I think that Pi-hole isn’t working and the router is switching to AdGuard’s DNS server. It is on my local network; no public IP or anything.

Debug Token:

62ahlpcnm3


#2

Can you post screenshot ?
Look for a “DHCP server --> DNS” or similar settings on the router and post screenshot as well please ?
If you have at one stage 3 DNS servers configured for resolution with the Pi-hole IP being one of them, this is not going to work.
The client(s) will query all three DNS servers, depending OS implementation, including the DNS servers that are not Pi-holed so ads will still leak through.


#3

I’ve found that my router i unusual; there are no DHCP settings. The DNS Server settings are under “Internet”. Here is that screenshot:

And here is the admin dashboard of Pi-hole:

I’m sorry it took so long to get back to you; classes just started and I’m swamped with work. I tried setting all the DNS addresses to 10.0.0.2 but there was no Internet connection.


#4

It looks like the router does not support local IPs at this place (rebind protection), because this DNS setting is different to the DNS-Setting for your local Network.

What manufacturer and model is your router?
Did you get it from your ISP?
If it is an Netgear model, is there a section called “LAN IP” or “LAN Setup”?
If you find there an option to disable the router’s DHCP function, then you could use Pi-hole’s built-in DHCP server.
If you can’t find such an option, maybe other users with the same device can help you.


#5

We have an FAQ on this subject.

Yes, make sure you are setting the DNS server in the correct area (LAN not WAN).


#6

What manufacturer and model is your router?

It’s a Netgear WNR2000V3

Did you get it from your ISP?

Yes, I did

If it is an Netgear model, is there a section called “LAN IP” or “LAN Setup”?

There is an option called “LAN Setup”

If you find there an option to disable the router’s DHCP function, then you could use Pi-hole’s built-in DHCP server.

I had forgotten about this option/feature! Thank you for reminding me! I’ll look into and get back to you on whether or not it works!

EDIT:

Configuring Pi-hole to act as the DHCP server did not work. I enabled Pi-hole’s DHCP option before I disabled my router’s and once I did, There was no network for me to connect to, for some reason. I ended up having to factory reset my router before I could use it again.


#7

Did you try restarting your devices after turning on Pi-hole’s DHCP server?