How to get Pihole to start blocking ads

#1

I’m trying to get Pihole to block ads on my Roku TV. I followed the directions in this link here:

And all seems to work fine, I can log into Pihole admin, and I changed the DNS settings on my router and followed the Pihole directions on that. But it doesn’t seem to be working. I added all the Roku links to the blacklist seen on this link here:

But it’s still showing ads, and the Pihole admin shows 0 queries, and doesn’t seem to be showing any activity. I did reset everything after this was all done as well.

Please let me know what/if you need any additional info. I am sorry in advance, I’m not very tech savy, so please try to explain things to me as basic as possible, it’s possible I missed a very basic step.

0 Likes

#2

If this is the case, you have a configuration problem that is preventing client DNS queries from reaching the Pi-Hole. Accordingly, ads are not being blocked.

Please generate and upload a Pi-Hole debug log and post the token here.

0 Likes

#3

Ok, here is the copy of the debug:

Edited by moderator to make debug log private.

0 Likes

assigned diginc #5
0 Likes

#6

Try the image:tag pihole/pihole:dev, it has the fix for this. The production image should get updated in the next day or so with this.

0 Likes

#7

I really appreciate your help, is that a command I input into CMD on Windows? I’m sorry, like I said, I’m not very techy. Or if the production image is updated, should I just remove and reinstall it?

Thanks again!

0 Likes

#8

That should go into your dockerfile it is a docker image

0 Likes

#9

pihole/pihole image has been updated to be 4.2.2, it should have the fix. Follow docker update instructions to pull and replace your old container with the new version.

If you’re still having problems make sure you delete your docker volume adlists.list file to re-populate.

0 Likes

#10

Much appreciated, I’ll give it a try tonight and follow up later.

One quick question, and I’m sure this is a dumb question, but do I set the Server IP to my IPv4 address or the gateway address?

0 Likes

#11

Ok, so I’m still having the same issue. Everything seems to be going smoothly, so I feel like it’s a simple mistake that I’m making. I did run the debug log again if you are interested. But here is what I did:

-Docker is installed
-I ran CMD as administrator, and Docker Pull pihole/pihole
-Everything downloaded and extracted smoothly.
-I deleted the contents in the pihole folders in documents and here is my run command:

docker run -d --name pihole -p 53:53/tcp -p 53:53/udp -p 80:80 -p 443:443 -v “/c/Users/econd/OneDrive/Documents/pi-hole-config/pihole/:/etc/pihole/” -v “/c/Users/econd/OneDrive/Documents/pi-hole-config/dnsmasq.d/:/etc/dnsmasq.d/” -e ServerIP=“192.168.0.1” -e WEBPASSWORD=admin --restart=unless-stopped pihole/pihole:latest

-Everything still went smooth and re-populated the pihole folders in documents

-I went into my router, turned off auto DNS, and set the primary DNS to 192.168.1.250 and deleted the secondary DNS. Then I went into settings in pihole, unchecked the Google DNS boxes and checked the OpenDNS IPv4 boxes

-I restarted everything, including the router, and still showing 0 queries. I’m not sure if this indicates something, but the only way I can log into pihole is by going to 192.168.0.13/admin, which is the IP address for my laptop where I’m setting this up. You’ll notice in the run command above, the serverIP was set to 192.168.0.1.

Please let me know if I did something incorrectly, or if you would like any additional info.

0 Likes

#12

ServerIP is not required anymore, you can remove it all together based off your docker run command having port forwards. ServerIP is meant for the default old blocking mode which sent blocked ads to a ‘blocked page’ on the Pi-hole, so it should match the IP of your container - but again it is now not require and you should remove it probably. Sounds like it was part of your confusion.

Why set your router DNS to 192.168.0.250? If your laptop is hosting Pi-hole on 192.168.0.13 then that is what your DNS should be configured to.

0 Likes

#13

I’m a welder, I don’t even know what a DNS is lol. I’m sorry, I know this is probably very frustrating for you trying to explain this all to me. That was what the DNS was set to on the Pihole instructions here:

Like I said, I really have no idea what I’m doing here, so it’s probably something very simple I missed or messed up. I just assumed that was a set number for the DNS. I’ll change that when I get home from work and hopefully that fixes everything.

0 Likes

#14

No worries, everyone has to learn somehow. I see, that guide should probably spell it out a little clearer that that screenshot should match whatever IP address your Pi-hole is on.

Another thing, you’ll want to make sure 192.168.0.13 is static IP or the number at the end (13) might change and your router will be pointed to no where for DNS.

Also are you planning on leaving that laptop running Pi-hole all the time?

0 Likes

#15

The laptop is the only computer I have in the house. Does it still work if the laptop is closed? Or turned off? Is it not recommend to have it running all the time on a laptop?

I’ll check on the IP address as well. If it’s a dynamic IP address, I just need to change it to a static one, correct?

0 Likes

#16

Your home network would likely not work when your laptop is off/asleep. My concern was if you have any secondary devices on your network ever, including cell phones on WiFi, you’re going to need Pi-hole online which means your laptop would have to be running. Otherwise DNS will be busted and internet without DNS is unusable, unless you like memorizing IP addresses of websites.

Yes on the static IP question.

0 Likes

#17

What’s typically done then, is pihole set up on a desktop computer that’s always on? Are there other options?

0 Likes

#18

A good “always on” option that does not require much power is a Raspberry Pi Zero or Zero W or a Nano Pi NEO, or similar SBC. These devices typically draw one watt or so and run very reliably in 24/7 use.

Typically with these devices, Pi-Hole is installed directly on the OS and not run in docker.

0 Likes

closed #19

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes